Please update M312-vagrant-env.zip

hi,
the VM won’t provision because of a psutil issue:
m312: error in psutil setup command: ‘extras_require’ must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.

the issue is that psutil wants to be managed by pip3 instead of pip. you can get around this by updating the vagrant script provision-m312 as follows:

function install_python_dependencies(){
sudo apt-get install -y python-dev
sudo apt-get install -y python-pip
sudo pip install pymongo
sudo pip install docopt
sudo pip install faker==3.0.0
sudo pip install psutil==5.6.0
sudo pip install mtools==1.5.3
}

(added ==5.6.0 to the end of the psutil line)
this will install an older version of psutil that is python2-friendly, and the provision is successful.

of course, you need to update everything to python3 at some point… :wink:

-jeff

3 Likes

Thanks, Jeff. It worked like a charm. :slight_smile:

1 Like