Pip installation errors

Getting the following error. I am using Python 3.7.0

ipython 7.2.0 has requirement prompt-toolkit<2.1.0,>=2.0.0, but you’ll have prompt-toolkit 1.0.15 which is incompatible.

Hello,

This is what someone suggested me and it worked for me.

pip uninstall jupyter-console
pip uninstall prompt-toolkit
pip uninstall jupyter

pip install -U jupyter-console
pip install -U prompt-toolkit
pip install -U jupyter

Thanks,
Shaul

1 Like

Thanks Shaul, this worked for me too. I also had to do the same for pytest-flask to run the pytest modules correctly.

1 Like

OK. Thank you for mentioning about pytest errors. I also will have to fix those errors.