Nothing provides /usr/libexec/platform-python needed by mongodb-enterprise-tools-4.2.14-1.el8.x86_64

The principal Reason might be, the following:

in every sudo dnf update, I’ve got this message:

  • nothing provides /usr/libexec/platform-python needed by mongodb-enterprise-tools-4.2.14-1.el8.x86_64

In this case, it is looking for the /usr/libexec/platform-python file which is not provided by any package in Fedora. It probably is in EL/CentOS.

This is my Repo /etc/yum.repos.d/:

[mongodb-enterprise]
name=MongoDB Repository-Enterprise
baseurl=https://repo.mongodb.com/yum/redhat/8/mongodb-enterprise/4.2/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-4.2.asc

[mongodb-community]
name=MongoDB Repository-Community
baseurl=https://repo.mongodb.org/yum/redhat/8/mongodb-org/4.4/$basearch/
gpgcheck=1
enabled=0
gpgkey=https://www.mongodb.org/static/pgp/server-4.4.asc

I’ve got both Repo because I’ve used MongoDB Atlas for studying your Course and MongoDB Community inside a Docker container for practice more…

Could you Please fix it???

as you can see here:

mongodb-enterprise-tools-4.2.13-1.el8.x86_64
mongodb-compass-1.26.1-1.el7.x86_64
mongodb-enterprise-shell-4.2.14-1.el8.x86_64

I’ve could upgrade mongodb-enterprise-shell-4.2.14-1.el8.x86_64 but not tools…

Regards.,