Not able to install mongodb-enterprise-server on 20.04 LTS

Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘mongodb-enterprise-server’ instead of ‘./mongodb-enterprise-server_4.4.1_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libcurl3 (>= 7.16.2) but it is not installable
Depends: libsensors4 (>= 1:3.0.0) but it is not installable
Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installable
E: Unable to correct problems, you have held broken packages.

My system arch —> x86_64

Later tried manually installing dependency Its says upgraded versions already install.
below error Iam getting:
misal@desktop:~/ $ sudo apt install libcurl3
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libcurl3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libcurl4:i386 libcurl4

Hi @Misal_Raj,

Can you please try download the package directly from the MongoDB Download Centre ?

Please select the right version of operating system.

~ Shubham