Not able to follow the steps mentioned in "Setting Up the Vagrant Environment"

I have installed Virtual box, mingw and Vagrant on my Windows 7.1 laptop.

Now as per the instruction, I have created three blank folder.
C:\university\m103\m103-vagrant-env>

Created three folders and inside that fired following command.
C:\university\m103\m103-vagrant-env>vagrant up

It is giving me following error…
“A Vagrant environment or target machine is required to run this
command. Run vagrant init to create a new Vagrant environment. Or,
get an ID of a target machine from vagrant global-status to run
this command on. A final option is to change to a directory with a
Vagrantfile and to try again.”

It seems I am missing something. Can you please help.

It seems I need to copy contents of this folder “m103-vagrant-env” to my created folder. Where can I get those contents.

Having installed the vagrant and virtual boxes.

Run a cmd shell from the m103-vagrant-env folder and run the command you just mentioned. Assuming that you have unzipped the m103-vagrant-env.zip into there.

For instance I unzipped the file into

C:\Dropbox\MongoDB\M103 - Basic Cluster Administation\Chapter 0 - Introduction and Setup

And kickstart my vagrant environements from in there.

Where you unzip the package to, doesn’t really matter as long as you are in the folder, at a command prompt when you setup the vagrant environment for the course, which is not the same as installing vagrant.

If you are not aware you, can type cmd in the folder path on windows explorer and it will open a command shell in that directory. Saves on CDing around the command shell.