Not able to connect to the cluster in compass

whenever i am trying to connect, it’s displaying “AUTHENTICATION FAILED”. i have followed all the steps whatever has been mentioned.

Do you tried ping cluster0-shard-00-00-jxeqq.mongodb.net?

Can you post a screenshot of your connection settings screen?
It should be the same as below:

Hi Adarsh_36096,

Please check your username and password. It should be:

  • username: m001-student

  • password: m001-mongodb-basics

Make sure you don’t have space in any field.

For more information, please check Chapter 1 post

Thanks, Kanika

I was facing the same issue of not connecting to the cluster in compass even though all of my connection details were correct. I uninstalled the compass and download community version, working fine on my machine now.

2 Likes

But you don’t able to see the schema view with the community version.

Hi Everyone,

Just wanted to underline that for this course you will need the Compass Stable version, which you can try out for free. The Compass Community versions lack specific functionality that is used in some of the lessons.

Again, MongoDB Compass Enterprise (Stable) is free of charge for evaluation purposes. Download from here.

Thanks, Kanika

Hello Kanika,

I’m using the 1.15.4 version of Compass, but I’m not able to connect my sandbox DB. I have read all discussions here and followed your advices to set the Replicate Set name, to set Primary Preferred… etc. Also, checked the connection with ping - it is OK.

Do you have any other advice to make the connection alive?

Thanks in advance.

Hi Zoltan_68470,

Everything is perfect!

Just remove :27017 from your Hostname.

It should be: sandbox-shard-00-00-asggn.mongodb.net

The port is mentioned just below that so we don’t need to specify.

Kanika

Thanks, Kanika,

this works!

Best regards,

Zoltán Mede

Kanika Singla mongodb_university@discoursemail.com ezt írta (időpont: 2018. okt. 23., K, 15:30):

2 Likes

Hello @Kanika
I’m unable to connect to the host even after entering the following credentials.
Please help me.

Hi Joshua_00418,

Please take a look here . Let me know if you have any issues!

PS: Restarting compass mostly solves problem :slight_smile:

Kanika

Hi @Kanica,

Not able to connect to the cluster (even disabling the local firewall).
Uninstalled and reinstalled Compass many times (version 1.19.12, Stable Version).
All network checks passed.

Thanks,
Gianluca

Hi @Gianluca_57531,

Please confirm that port 27017 is not blocked by clicking http://portquiz.net:27017.

If successful, you will see a page load that indicates you can make outgoing requests on port 27017.

If a page does not load and your request eventually times out, outgoing traffic to port 27017 is probably blocked on your local network. If this is the case, please contact your IT department to see if there is a workaround or try to make the request from another location.

If this is not the case then I would recommend you to check this great post by @Kanika on Compass related issues.

If the issue still persists, please feel free to get back to us.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi Shubham

yes, I’ve already checked that http://portquiz.net:27017](http://portquiz.net:27017/ works as expected:

Moreover, all tests suggested in the post you mentioned passed. So, what could I do more?

Thanks, Gianluca

Hi @Gianluca_57531,

Can you please tell me your operating system specifications ?

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi @Shubham_Ranjan,

Windows 10.0.18362

Regards,
Gianluca

Hi @Gianluca_57531,

Can you please try to install the 1.16.4 version of the Compass and see if this helps.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi @Shubham_Ranjan,

yes, this version works! Thank you very much for your great help.

Regards,
Gianluca