Not able to connect to Sandbox cluster for me from Compass

Hi I tried to connect to the sandbox cluster for me from Compass and I am not able to connect using the sandbox cluster I get from the Atlas connection I have. The cluster details I have on Atlas is Primary “cluster0-shard-00-00-34wyl.azure.mongodb.net” and username I used is Username: “m001-student”
Password: “m001-mongodb-basics”. Am I doing the correct connection parameters? Let me know.

Thanks
Mathew George

Hi @Mathew_George_13984,

Can you please share the screenshot of the connection parameters that you have filled in and the error message that you are getting on the connection screen. Also please make sure your port is not blocked by opening http://portquiz.net:27017/.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

hostname: cluster0-shard-00-00-34wyl.azure.mongodb.net

I am able to connect using compass with the following parameters which is in the document or study text, but the database only has the “movies” collection not the movieDetails collection which I loaded. May be I loaded the MovieDetails collection to a different cluster and I am not able to connect to the cluster using the compass for some reason.

I am able to connect to compass using this parameters.

Hostname: cluster0-shard-00-00-jxeqq.mongodb.net
Username: m001-student
Password: m001-mongodb-basics
Replica Set Name: Cluster0-shard-0
Read Preference: Primary Preferred

1 Like

Hi @Mathew_George_13984,

The connection parameter that you have shared here is for Class Atlas Cluster not your Sandbox cluster.

Can you please share the connection string of your Sandbox cluster that you have used to connect from mongo shell while loading the data?

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi Shubham,
This is the connection parameters I used to load the data.

mongo “mongodb+srv://cluster0-34wyl.azure.mongodb.net/test” --username mgeorge --password Mongo123#$

If the sandbox cluster is different could you please let me know how to connect to that?

Hi @Mathew_George_13984,

Please check your discourse inbox.

[Edit] :

I am not able to connect to your sandbox cluster using the connection string that you have provided. Can you please make sure all the IP addresses (0.0.0.0./0) are white listed for connection to your cluster.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi,

I am trying to load the load(“loadMovieDetailsDataset.js”) and getting errors. Looks like the database video is already there. Can you please check?

Mongo shell connection parameters to Sandbox

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?replicaSet=Cluster0-shard-0” --authenticationDatabase admin -ssl -username m001-student --password m001-mongodb-basics

Hi… Is anybody available to help so that I can continue…

Hi @Mathew_George_13984,

This is the Atlas class cluster not your sandbox cluster. You do not have permissions to load any data in this cluster. Please connect to your Sandbox cluster and then load the data into that cluster.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Am I connecting to Atlas class cluster now with the following command. I took it from the text for the class to connect to cluster? It is the sandbox cluster right?

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?replicaSet=Cluster0-shard-0” --authenticationDatabase admin -ssl -username m001-student --password m001-mongodb-basics

If it is wrong… how to connect to sandbox cluster?

Hi @Mathew_George_13984,

Yes, you are connected to the Atlas class cluster which is owned by MongoDB. Please refer this post that I have made earlier to understand the difference between Atlas Class cluster and the Sandbox cluster.

Please refer this post and follow the instructions.

If anything in the posts is not clear to you then please get back to us.

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi,

I am confused… Why it is showing Sandbox under the cluster? See screenshot.

It is asking for credit card information for a new cluster with .54/hour. Not letting me to select a M0 cluster without payment? Any idea.

Hi @Mathew_George_13984,

Please follow the steps mentioned below to get the connection string to connect to your cluster.

Click on Clusters

Click on CONNECT

Click on Connect with the Mongo Shell

Click on I have the Mongo Shell installed and then make sure you have selected 3.6 or later.
Finally click on Copy at the bottom to copy the connection string.

Paste the connection string in the terminal and the prompt will ask for password. Enter the password that you have set for the given user in your cluster.

For every account you can have just one free tier M0 cluster and that’s why you are not able to create another free tier cluster.

You do not need to create another cluster as you are already having one.

I would request you to go through this lab Lecture: Lab 2.0: Create an Atlas Sandbox Cluster (Ungraded) again and make sure you have not missed any steps.

Make sure you have updated your IP Whitelist (0.0.0.0/0) so that your app can talk to the cluster from all the locations.