Not able to connect to M121 Course Atlas Cluster

Getting the following error while executing connection command mentioned in chapter 0, lecture 2. Please help

Welcome to the community!

You are already at mongo prompt
Please exit and run the command from your os prompt

Tried, not able to connect. Sharing the screenshot below

Is mongo installed on your box?
If yes have you updated/included mongo/bin to your path?
You can go to bin dir and run the command again
If it works it is PATH problem

I’am strugling with the same issue , trying to connect to the cluster from my Git Bash terminal :

2 questions :

  • Should I connect to the cluster from the mongo Shell or from the Git bash terminal ?

It seems that if I connect from the Git bash the mongo command is not recognized and if I connect from the mongo shell I will get the same syntax error he did.

  • If I’am already connected to a cluster in the mongo shell , as I seem to be , how do I connect to a different cluster ?

At exactly the same place same shell where you type ./mongo, just do it with the connection string.

1 Like

Hello everyone, facing the same issue, but not getting proper solution on it, please help out.

What do you mean by not getting proper solution? The proper solution is above. If you are

that is SyntaxError: unexpected token…, then the solution is to exit the mongo shell and run the given command outside the mongo shell. The solution already proposed.

yes , yes !!! That is the way to go man !!

Yes, on the right way, I haven’t set the path, and thats why i was facing the issue, thank you @steevej

Hey All,

We highly appreciate the community members supporting each other and resolving the issues. :clap:

I would like to add the documentation link for Installing MongoDB Enterprise in this thread for any future reference.

Please feel free to reach out if you have any additional questions.

Kind Regards,
Sonali Mamgain