Not able to connect to Atlas

Right after the installation, I’ve ran this command:

C:\Users\crisf>“C:\Program Files\MongoDB\Server\4.0\bin\mongo.exe”

Resulting on this:

MongoDB shell version v4.0.6
connecting to: mongodb://127.0.0.1:27017/?gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“ca83b4a5-e025-4ac9-8a73-b87256b7bdec”) }
MongoDB server version: 4.0.6
Welcome to the MongoDB shell.
For interactive help, type “help”.
For more comprehensive documentation, see
http://docs.mongodb.org/
Questions? Try the support group
http://groups.google.com/group/mongodb-user
Server has startup warnings:
2019-02-13T18:53:36.575-0700 I CONTROL [initandlisten]
2019-02-13T18:53:36.575-0700 I CONTROL [initandlisten] ** WARNING: Access control is not enabled for the database.
2019-02-13T18:53:36.575-0700 I CONTROL [initandlisten] ** Read and write access to data and configuration is unrestricted.
2019-02-13T18:53:36.575-0700 I CONTROL [initandlisten]

Enable MongoDB’s free cloud-based monitoring service, which will then receive and display
metrics about your deployment (disk utilization, CPU, operation statistics, etc).

The monitoring data will be available on a MongoDB website with a unique URL accessible to you
and anyone you share the URL with. MongoDB may use this information to make product
improvements and to suggest MongoDB products and deployment options to you.

To enable free monitoring, run the following command: db.enableFreeMonitoring()
To permanently disable this reminder, run the following command: db.disableFreeMonitoring()

So I pasted the command to connect to Atlas:

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

This is the message I’m receiving:

2019-02-14T00:07:51.223-0200 E QUERY [js] SyntaxError: missing ; before statement @(shell):1:clock6:

Not sure what is wrong, could someone help me, please?

Just solved. I realized I should run it from the following directory, instead of mongoshell:

C:\Program Files\MongoDB\Server\4.0\bin\

Sorry, I misread.

Yes! You are perfectly right! Good that you figured it out :slight_smile: