No matching distro of jupyter-console==6.0.0

Hi!

I am trying to install requirements.txt but I am not able :frowning:

(base) MacBook-Pro-de-Jorge:mflix-python jorgegarciaotero$ conda activate mflix
(mflix) MacBook-Pro-de-Jorge:mflix-python jorgegarciaotero$ pip install -r requirements.txt
Requirement already satisfied: Flask==0.12.4 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 1)) (0.12.4)
Requirement already satisfied: Flask-Bcrypt==0.7.1 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 2)) (0.7.1)
Requirement already satisfied: Flask-Login==0.4.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 3)) (0.4.0)
Requirement already satisfied: pymongo==3.7.2 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 4)) (3.7.2)
Requirement already satisfied: dnspython==1.15.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 5)) (1.15.0)
Requirement already satisfied: pytest==3.3.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 6)) (3.3.0)
Requirement already satisfied: pytest-flask==0.10.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 7)) (0.10.0)
Requirement already satisfied: Flask-Cors==3.0.3 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 8)) (3.0.3)
Requirement already satisfied: flask-jwt-extended==3.7.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 9)) (3.7.0)
Requirement already satisfied: faker==0.8.13 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 10)) (0.8.13)
Requirement already satisfied: jupyter==1.0.0 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 11)) (1.0.0)
Requirement already satisfied: jupyter-client==5.2.4 in /usr/local/lib/python2.7/site-packages (from -r requirements.txt (line 12)) (5.2.4)

Collecting jupyter-console==6.0.0 (from -r requirements.txt (line 13))
Could not find a version that satisfies the requirement jupyter-console==6.0.0 (from -r requirements.txt (line 13)) (from versions: 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.1.0, 4.1.1, 5.0.0b1, 5.0.0, 5.1.0, 5.2.0)
No matching distribution found for jupyter-console==6.0.0 (from -r requirements.txt (line 13))

By the way, when write the pip freeze install -r requirements.txt command it returns that i need this 2 files:
Requirement file [requirements.txt] contains flask-jwt-extended==3.7.0, but that package is not installed
Requirement file [requirements.txt] contains faker==0.8.13, but that package is not installed

but when I insert both pip install commands console returns that both requirements are already satisfied.

I tried both in conda and virtual environment.

I also have one more question. Where do I have to execute “pytest -m LAB_UNIT_TEST_NAME” or “pytest -m connection”, inside the mflix conda environment or outside? I assume its inside, with to terminals with the mflix environment activated, one for running the .py and the other one for testing.

Thanks in advance :slight_smile:

kind regards.

I am not sure if you can carry on with Python 2.7 version. If you also have python 3 version, you might want to use pip3 instead of pip.

Inside the environment from mflix-python directory.

Kanika

Thanks for replying :slight_smile:

pip3 solved the requirements part, so everything is installed.

About the pytest part, it didnt work inside de environment, but by upgrading pytest worked outside.

kind regards.

1 Like