"No guest additions were detected" error on Infrastructure only

Hi. I am on Windows 10. The setup of the “database” vbox went fine with no errors, in the log I see:

database: Checking for guest additions in VM…
database: Guest Additions Version: 4.3.40

and everything works, the shared folders get properly mounted and I can see the test.txt file.

However, when the “infrastructure” vbox initiates, it cannot find the guest additions, and reports this:

infrastructure: Checking for guest additions in VM…
infrastructure: No guest additions were detected on the base box for this VM!

and then I get the error:

infrastructure: Rsyncing folder: /cygdrive/c/Temp/m310-vagrant-env/ => /vagrant
infrastructure: Mounting shared folders…
infrastructure: /home/vagrant/shared => C:/Temp/m310-vagrant-env/shared
Vagrant was unable to mount VirtualBox shared folders. This is usually because the filesystem “vboxsf”
is not available. This filesystem is made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the guest. This is not a bug in Vagrant and is usually caused by a faulty Vagrant box. For context, the command attempted was:
mount -t vboxsf -o uid=1000,gid=1000 home_vagrant_shared /home/vagrant/shared
The error output from the command was:
mount: unknown filesystem type ‘vboxsf’

I have spent about 2 hours now searching and reading all the posts on this forum about this error, and Googling this issue. Nothing has worked. I have tried every variation of “reload”, “provision” and “up” commands I could think of (so please do not tell me to do any of the following again! :slight_smile: ) - like these:

  1. vagrant plugin install vagrant-vbguest
    vagrant reload infrastructure
    vagrant provision infrastructure

  2. vagrant destroy infrastructure
    vagrant plugin install vagrant-vbguest
    vagrant up infrastructure

No variation makes any difference. I have even rebooted and still the same. Why does it work OK for the “database” vbox but not the “infrastructure” vbox?

Yes most of the vboxsf issues are fixed by above steps
Other suggestions
1.May be download was not complete or blocked by antivirus etc
2.Did you try fresh removing old vagrant files
3.It could be version issues of VM,virtual box,vagrant
4.Order of bringing up has helped for one student
vagrant up database
install plugin
vagrant up infrastructure
5.plugin version
Below seem to have fixed the issue in other course
vagrant plugin update vagrant-vbguest vagrant destroy
$ vagrant up

Thanks for the reply @ Ramachandra_37567! Unfortunately, nothing seems to help. Here is what I have done:

  1. Downgraded VirtualBox from 6.1 to 6.014 as recommended. Rebooted after uninstall and then again after re-install, and made sure the vbox extensions version matched the vbox version. Still got the error.
  2. Uninstalled vagrant,re-downloaded and installed version 2.2.13 - latest version. Still get error.

Again I have tried every combination of up/destroy/reload/provision with updating/installing the guest additions that I could think of. No good.

What I still don’t understand is that the “database” setup runs fine, sees the guest additions, and mounts the folders properly. Everything works for that instance. But for “infrastructure” it doesn’t work.

Has anyone recently successfully setup the “infrastructure” environment with the latest version (2.2.13) of vagrant?

OK, once again it seems the issue is in the latest version of Vagrant. I uninstalled version 2.2.13, and installed 2.2.10 (I know 2.2.11 has a bug with ssh from previous attempt!). Installed the guest plugin, ran “vagrant up”, and yes - no issues, everything was setup fine and mounted share works now on Infrastructure environment. So I am good to go now.

One thing different I did notice… in both environments there is a big difference in the command line functions being executed between the two vagrant versions - 2.2.10 installed a lot of dependencies and then used the Vbox Guest Additions ISO to install the guest plugin - which version 2.2.13 did not do. Command line output (did not see this in vagrant 2.2.13):

[database] A Virtualbox Guest Additions installation was found but no tools to rebuild or start them.
Stopping VirtualBox Additions
…done.
Removing virtualbox-guest-dkms (4.3.40-dfsg-0ubuntu14.04.1) …
-------- Uninstall Beginning --------
Module: virtualbox-guest
Version: 4.3.40
Kernel: 3.13.0-170-generic (x86_64)
-------------------------------------
DKMS: uninstall completed.
Copy iso file C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso into the box /tmp/VBoxGuestAdditions.iso
Mounting Virtualbox Guest Additions ISO to: /mnt
mount: block device /tmp/VBoxGuestAdditions.iso is write-protected, mounting read-only
Installing Virtualbox Guest Additions 6.0.14 - guest version is 4.3.40

So, someone should check with Vagrant - seems to be a bug in version 2.2.13.

1 Like

I have the same issue on WIndows 10. Both VMs were created, database VM was created fine, but infrastructure VM had error messages, starting with: [infrastructure] No Virtualbox Guest Additions installation found.
I tried all possible combination suggested earlier.
Even installed downgraded versions to recommended by Darvin, but still no luck.
As a result of the errors /shared folder was not created on infrastructure VM. So sync cannot be done. Final error message goes like this:
==> infrastructure: Checking for guest additions in VM…
infrastructure: No guest additions were detected on the base box for this VM!
Need help.

Did you try vagrant plugin vbguest

vagrant destroy infrastructure
vagrant up infrastructure
vagrant provision infrastructure

yes, I did. it end up with the same problem. strange that database vm was created just fine, interesting that promt for it was vagrant@database, but for infrastructure vagrant@localhost is that how it supposed to be, I was expecting vagrant@infrastructure ?

I am providing the sequence where error happened: 1. No package kernel-devel-3.10… available.
2. Error nothing to do
3. Unmounting Virtualbox Guest Additionions … ISO and immediately after that checking for it and it is no there anymore.
I am not a Linux person, but looks like something is wrong with fastestmirror server. Can we select another place to load from, may be it will have package kernel-devel-3.10…

as a result, when I run ssh to infrastructure I got this

C:\vms\m310-vagrant-env>vagrant ssh infrastructure
Last login: Sun Nov 22 23:50:15 2020 from 10.0.2.2
Last login: Sun Nov 22 23:50:15 2020 from 10.0.2.2
[vagrant@localhost ~]$ cat ~/shared/test.txt
cat: /home/vagrant/shared/test.txt: No such file or directory

It says no guest additions detected
Did you run vagrant plugin install vagrant-vbguest step?

Yes the prompt should look vagrant@infrastructure

When my setup got to that point, it detected I had the Guest Additions installed and copied the iso from the Virual Box folder - which the Virtual Box setup put in C:\Program Files\Oracle\VirtualBox - didn’t have to download anything.
image

I have this file in the same location, but it has completely different size and date stamp, by the way all your files are much newer than mine. Did I get wrong version of the Virtual Box? It should be something like this, I have the same errors on 2 different machines with Windows 10 home and Windows 10 Pro. So it is not environments, but could be versions.

Here is my version of VirtualBox

Yes, I did, I even run vagrant up commands separately for different vms, like this:
vagrant plugin install vagrant-vbguest
vagrant up infrastructure
vagrant provision infrastructure

still, vm created but with errors and prompt [vagrant@localhost ~]$

while
vagrant plugin install vagrant-vbguest
vagrant up database
vagrant provision database

was fine every time

For Virtual Box I had initially version 6.0.14, and once I got it working, I upgraded to 6.1.16, that’s why.

What version of Vagrant are you running? I had problems with the 2.2.13 version, had to downgrade to 2.2.11. Have you tried that?

I had it at 2.2.10 based on your original post, then I uninstall it and install 2.2.14 with the same result.
So, may I asked what versions you made it worked on. Obviously combination of Vagrant 2.2.10 and Virtual Box 6.014 did not work for me. The same is true for 2.2.14 and 6.014. May be I need to uninstall and re-install Virtual Box as well to clean things up?

As I mentioned, 2.2.11 Vagrant and VBox 6.0.14 or 6.1.16 worked for me.