My mflix application is not able to connect to atlas

Hi, I have set up mflix application following the steps provided. At the step for checking connection

pytest -m connection
I am getting errors Fixture config not found, Fixture client not found ,some body help me please.

Did you run pip install -r requirements.txt ?

Kanika

Now i run this command, tried again, still getting the same errors

What is the version of dnspython?

Kanika

python 3.8.1

Try work on mflix application after activating a virtual environment or anaconda. Looks like a problem with dependency.

Kanika

i have upgraded dnspython==1.16.0, also tried the second fix by changing requirements.txt. Still no luck

Tried all the steps, still no use. Same error I am getting

Are you using anaconda or virtual env?

i am using anaconda

I reinstalled anaconda and tried again, when i am running this command pip install -r requirements.txt i can see an error ERROR: pyzmq has an invalid wheel, multiple .dist-info directories found: pyzmq-18.1.0.dist-info, libsodium-1.0.17.dist-info
again i have installed packages independently, still i am reaching to the initial error

You need to run this command after activating mflix through anaconda. Please share a screenshot of the full error, so that we can help you out.

Kanika

Here is my connection string
[PROD]
SECRET_KEY = super_secret_key_you_should_change
MFLIX_DB_URI = mongodb+srv://m220student:m220password@mflix.../*?retryWrites=true&w=majority
MFLIX_NS = sample_mflix