MongoDB PHP Extension 1.8.0 Released

The PHP team is happy to announce that version 1.8.0 of the mongodb PHP extension is now available on PECL. This release adds support for new features in MongoDB 4.4.

Release Highlights

This release introduces support for OCSP and OCSP stapling, which is used to validate the revocation status of TLS certificates. OCSP is enabled by default, but can be controlled via two new URI options: tlsDisableOCSPEndpointCheck and tlsDisableCertificateRevocationCheck. The existing tlsAllowInvalidCertificates and tlsInsecure URI options may also be used to disable OCSP.

The driver now supports a directConnection URI option, which can be used to control replica set discovery behavior when only a single host is provided in the connection string. By default, providing a single member in the connection string will establish a direct connection or discover additional members depending on whether the replicaSet option is omitted or present, respectively. This default behavior remains unchanged, but applications can now specify directConnection=false to force discovery to occur (if replicaSet is omitted) or specify directConnection=true to force a direct connection (if replicaSet is present).

The driver now supports Zstandard compression if it is available during compilation. Applications can opt into using Zstandard by specifying zstd in the compressors URI option, which is used to negotiate supported compression formats when connecting to MongoDB.

The ReadPreference constructor now supports a hedge option, which can be passed ['enabled' => true] to enable Hedged Reads when connected to a MongoDB 4.4 sharded cluster.

This release adds several authentication improvements. The driver supports the new MONGODB-AWS authentication mechanism, which can be used when connecting to a MongoDB Atlas cluster that has been configured to support authentication via AWS IAM credentials. Additionally, the driver now uses a shorter conversation with the server when authenticating with a SCRAM mechanism.

MongoDB\Driver\BulkWrite::update() now supports a hint option, which can be used with MongoDB 4.4 or later.

The Manager constructor now supports a driver option in its $driverOptions parameter, which can be used by wrapping drivers and libraries to append metadata (e.g. library name and version) to the server handshake.

This release upgrades our libbson and libmongoc dependencies to 1.17.0. Support for PHP 5.6 has been removed and the extension now requires PHP 7.0 or newer.

A complete list of resolved issues in this release may be found at: https://jira.mongodb.org/secure/ReleaseNote.jspa?projectId=12484&version=24483

Documentation

Documentation is available on PHP.net:
http://php.net/set.mongodb

Feedback

We would appreciate any feedback you might have on the project:
https://jira.mongodb.org/secure/CreateIssue.jspa?pid=12484&issuetype=6

Installation

You can either download and install the source manually, or you can install the extension with:

pecl install mongodb-1.8.0

or update with:

pecl upgrade mongodb-1.8.0

Windows binaries are available on PECL:
http://pecl.php.net/package/mongodb

1 Like