Mongodb-org-server el8 package has dependency on python2

Hi.

I’ve just deployed MongoDB Community Edition to a CentOS 8 system using the repo detailed here:
https://docs.mongodb.com/manual/tutorial/install-mongodb-on-red-hat/

I noticed that the installation prompted a number of Python 2 packages to be installed as a dependency.

Querying the mongodb-org-server package confirms the dependency:
rpm -qR mongodb-org-server | grep python
python2

As Python 2 was sunset at the beginning of last year:

CentOS 8 uses Python 3 by default.

I’m not sure what the dependency on Python 2 is but, are there any known plans to move to Python 3?

I couldn’t find anything in either these forums or the issue tracker.

Thanks in advance.

It’s an interesting one too. There does not seem to be anything in the package that requires python.

Should I raise this in the issue tracker? Thanks.

I don’t see why not. :+1:

I don’t seem to be able to authenticate.

Does the issue tracker use the same credentials as the forums?

Yes it does, for me at least. I think all forum accounts use sso now, that should work there too.

https://jira.mongodb.org/plugins/servlet/samlsso?tracker=Y8TL8&idp=2&redirectTo=%2F

If it doesn’t work for you I might have time later to create an issue.

New issue created:
https://jira.mongodb.org/browse/SERVER-54057

Thanks.

1 Like