MongoDB not running on the provided host and port

I am getting error “MongoDB not running on the provided host and port” , after downloading compass and connecting to as per below.
Please suggest.

##############################
Hostname: cluster0-shard-00-00-jxeqq.mongodb.net

Username: m001-student

Password: m001-mongodb-basics

Replica Set Name: Cluster0-shard-0

Read Preference: Primary Preferred
##############################

Hi,
is the SRV Record field active or inactive?
Got the same error with this field enable

HTH Ralf

Forgive me if you already did this, but did you make sure you’re not being blocked by a firewall?

https://university.mongodb.com/mercury/M001/2018_October/chapter/Chapter_1_Introduction/lesson/5963b30cc1da5a32116dc5b3/tab/5963b30cc1da5a32116dc5b4

I just retried and it connected fine. I did not change anything, but worked.
Thanks for looking into it, Ralf, Matt.

Rama

1 Like

I’m having this problem too. I did the firewall test with no problems, but I’m still getting the error message. I tried doing it with “SRV Record” checked and unchecked, no difference.

Hi Kirstin_95006,

Have you tried everything mentioned here.
If you are still having trouble, let me know.

Thanks, Kanika

Ok I tried all those and it failed at telnet. Getting that fixed is not something I can do today or tomorrow, so I’m going to have to drop out of the course for now and sign up for the next one. Thanks.

Good Luck Kirstin_95006!
See you in the next offering!

Kanika

I get the same message with the field disabled

What to do for Ubuntu. Installation was smooth but doesn’t run. don’t know why. I am already running late. Planned to join for the next session.

I am just going ahead to create a new FREE ATLAS CLUSTER to follow the course.

same problem here: MongoDB not running on the provided host and port

Hi @Demetriusdasilva,

Have you tried everything mentioned here .
If you are still having trouble, let me know.

Thanks, Kanika

I have tried everything listed here How do check the network settings with the Admin?

Is ping cluster0-shard-00-00-jxeqq.mongodb.net working for you?
Is telnet working?
Are you trying from office or home
Did you try from another location
You have to contact your admin/IT team to unblock the ports/firewalls if that is what is preventing you

same issue for me.
when using corporate network, i have tried all the necessary test and it passed except the telnet…
when using raw internet i can’t even ping the host.

i cannot move on with the course…

Hi @Desert_30505,

Were you able to resolve this issue?

Please let me know, if you still face same issue.

Thanks,
Sonali

Not Really…
but i was able to connect to my local machine. i just installed mongodb and import the dump.zip i found from other thread

1 Like

HI @Desert_30505,

Please share the screenshot of output when you run following commands in terminal:

telnet cluster0-shard-00-00-jxeqq.mongodb.net 27017

ping cluster0-shard-00-00-jxeqq.mongodb.net

Also, make sure you are connected to the home network and you are not connected to VPN.

Edit: I can see that you have completed chapter 1. :clap:
So if you have any questions there, please let me know.

Thanks,
Sonali

Hi @Sonali_Mamgain,

The ‘ping’ is successful but the ‘telnet’ command says connection failed and could not open connection to the host.

Please advise.

Regards,
Preeti