MongoDB Host has stopped responding

During the course M001: MongoDB Basics we were suggested to connect to “cluster0-shard-00-00-jxeqq.mongodb.net:27017”, but looks like since a couple of hours this port 27017 has stopped working.

  • Ping test result is successful:
  • Telnet result failed
  • Mongo compass failed to connect with the error “MongoDB not running on the provided host and port

C:\Users\testuser>telnet cluster0-shard-00-00-jxeqq.mongodb.net 27017
Connecting To cluster0-shard-00-00-jxeqq.mongodb.net…Could not open connection to the host, on port 27017: Connect failed

C:\Users\testuser>ping cluster0-shard-00-00-jxeqq.mongodb.net

Pinging ec2-34-195-121-130.compute-1.amazonaws.com [34.195.121.130] with 32 bytes of data:
Reply from 34.195.121.130: bytes=32 time=210ms TTL=43
Reply from 34.195.121.130: bytes=32 time=211ms TTL=43
Reply from 34.195.121.130: bytes=32 time=211ms TTL=43
Reply from 34.195.121.130: bytes=32 time=212ms TTL=43

Mongo Compass result screenshot:
image

Please note that this connectivity was working perfectly fine when I was checking two days back. Is there any change in host or port for the course. I think somebody from course coordination team can help.

Hi @ChinmayAnand,

First of all there is no change in the host or port for the course. And as you mentioned you were able to connect to the cluster couple of days ago so there does not seems to be an issue with your firewall.

Can you please do the following :

  1. Delete your M001 RS favorite
  2. Restart the compass
  3. Recreate the M001 RS favorite

Let me know if the issue still persists. Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi @Shubham_13709,
May be you are correct.
During the error, I was connected to an external wifi network inside a local college campus.
But today when I tried to connect the Mongo Compass to the server for the course M001, from my office network, it is connecting. The recreation of “M001 RS” favourite was not needed.
You might have observed the telnet result was too unsuccessful at the college wifi.

Next time this happens again, I will check the firewall access regarding the port blockage there in the network.
For now we may consider the issue closed.
Thank you for your help.

Hi @ChinmayAnand,

It’s a wonderful news that your issue got resolved. If you face any other issue please get back to us.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Support Engineer