Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

Mongodb compass- freeze on activating plugins

Compass 1.21.2 is out: https://www.mongodb.com/download-center/compass.

1 Like

Hi, I have the same problem. I am using version 1.21.2 (Community Edition Stable) on Windows 8.1 Pro. I get the error as below:

image

Any idea how to get it working?

Thanks!

Seems it’s not an issue with MongoDB Compass in my case. I added C:\Windows\System32\Wbem to path and it solved the issue.

1 Like

@Wojciech_Sitkiewicz Hi, I have the same error you had. Just curious on how you troubleshot this. How did you figure out to update your path? I’m going to give your solution a try.

@Wojciech_Sitkiewicz Thanks, I was stuck on this for 3 hours and once I used your suggestion to add C:\Windows\System32\Wbem to my path, it worked.

For anyone wanting to try this fix I have MongoDB Compass 1.21.2 installed.

Ok I am experiencing the same issue. I think I know what the issue is.
If you are using Windows 7, and if you go to your Edit your environment variables and added
C:\Program Files\MongoDB\Server\4.2\bin, this will install your shell path.
But if you installed Mongo Compass DB it will just keep trying to activate plugins unless you change your environment variable to C:\Windows\System32\Wbem. But now you cant access your shell path.

So you have to create two paths. But the problem I am having now is what to name the shell path?

Yeah. I also had the same problem. Just added the following to my environment variables and it’s working.

Thanks alot !!

Hi,

I have updated the environmental variables. Still i am facing this issue.
Kindly help me to sort it out

1 Like

Same here. But in my case, I need to wait for approximate 10 minutes for Compass to run. Every time i run program.

there are five errors including one that says wmic command is not recognised as internal or external command