Mongodb compass- freeze on activating plugins

Hi Doug,

Thank you for your email. So “what is a bear’s favorite drink? = koka-koala!”, I downloaded the MSI package. Keep in mind I am following the MongoDB University slides at the moment, maybe that’s a great place to start.

Semper fi,

Hi Stennie,
Mongodb 1.21.0
Win 10 x64
I’ve had mongo for some time, and only recently (3 weeks ago) it started to lock up when activating plugins

Hi @Charlie_Maru, Compass 1.21.0 was released on April 28th (about two weeks ago). Is it possible that you updated around that time? If so it’s possible that the update did something. If you didn’t update then hopefully the MongoDB engineers can help you track down what’s going on.

Last week, we released Compass 1.21.1. It should fix some error conditions as well as print some useful error messages in the console of the loading screen if something goes wrong. Could you please give that a try?

Thank you!


i was told to use the isolated edition instead until the problem is fixed. it works out ok but how will i know when the problem is fixed? who will let me know ?

@Angelo_Hedley would you be able to try 1.21.1 (non isolated edition)? We fixed some of the potential issues in there but we’ve had a hard time reproducing the issue in our windows boxes. It’d be great to get some feedback from the community on whether the problem is really solved.

Quick update: we found the problem and fixed it. We will release Compass 1.21.2 with the fix very soon.

Thank you for the patience.


Compass 1.21.2 is out:

1 Like

Hi, I have the same problem. I am using version 1.21.2 (Community Edition Stable) on Windows 8.1 Pro. I get the error as below:


Any idea how to get it working?


Seems it’s not an issue with MongoDB Compass in my case. I added C:\Windows\System32\Wbem to path and it solved the issue.


@Wojciech_Sitkiewicz Hi, I have the same error you had. Just curious on how you troubleshot this. How did you figure out to update your path? I’m going to give your solution a try.

@Wojciech_Sitkiewicz Thanks, I was stuck on this for 3 hours and once I used your suggestion to add C:\Windows\System32\Wbem to my path, it worked.

For anyone wanting to try this fix I have MongoDB Compass 1.21.2 installed.


Ok I am experiencing the same issue. I think I know what the issue is.
If you are using Windows 7, and if you go to your Edit your environment variables and added
C:\Program Files\MongoDB\Server\4.2\bin, this will install your shell path.
But if you installed Mongo Compass DB it will just keep trying to activate plugins unless you change your environment variable to C:\Windows\System32\Wbem. But now you cant access your shell path.

So you have to create two paths. But the problem I am having now is what to name the shell path?

Yeah. I also had the same problem. Just added the following to my environment variables and it’s working.

Thanks alot !!


I have updated the environmental variables. Still i am facing this issue.
Kindly help me to sort it out

1 Like

Same here. But in my case, I need to wait for approximate 10 minutes for Compass to run. Every time i run program.

there are five errors including one that says wmic command is not recognised as internal or external command

this solution worked for me thanks

Hey add this to your path-


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.