MongoDB cluster administration

My mongod services are ‘Active’.
But when i try to enter mongo shell, following error occurs.
" Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused "

Hey @Nilesh_Patil

So that error means that mongod is not running. When you say that,

Is that coming from running following inside the vagrant VM?

ps -ef | grep mongod`

And on that note have you first ssh’ed into the vagrant machine?

Hope this helps!

@natac13
ps -ef | grep mongod
mongodb 19855 1 1 14:50 ? 00:01:13 /usr/bin/mongod --config /etc/mongod.conf
server1+ 19986 19039 0 16:08 pts/0 00:00:00 grep --color=auto mongod

This is what i am getting

@Nilesh_Patil
Ok looks like you have a mongod running with a config file located at /etc/mongod.conf

Which part of the course are you on? Chapter 1 Configuration File Video?
Is this all inside the vagrant machine?
And can you show the contents of that config file @ /etc/mongod.conf

@natac13

mongod.conf

for documentation of all options, see:

http://docs.mongodb.org/manual/reference/configuration-options/

Where and how to store data.

storage:
dbPath: /var/lib/mongodb
journal:
enabled: true

engine:

mmapv1:

wiredTiger:

where to write logging data.

systemLog:
destination: file
logAppend: true
path: /var/log/mongodb/mongod.log

network interfaces

net:
port: 27017
bindIp: my_ip_address, 127.0.0.1

how the process runs

processManagement:
timeZoneInfo: /usr/share/zoneinfo

security:
authorization: “enabled”
keyFile: /opt/mongo/mongo-keyfile

#operationProfiling:

replication:
replSetName: “rs0”

sharding:
clusterRole: “shardsvr”

Enterprise-Only Options:

#auditLog:

#snmp:

@Nilesh_Patil

It might be best to make sure you have your vagrant machine up and running from Chapter 0 and then work through the setup of the mongod and config file videos from Chapter 1 again.

@natac13
Ok.
Thank you