Mongodb -- Can it be installed on Elementary OS. I am getting error

Mongodb – Can it be installed on Elementary OS MongoDB enterprise . I am getting error

sudo apt-get install -y mongodb-enterprise=4.0.8 mongodb-enterprise-server=4.0.8 mongodb-enterprise-shell=4.0.8 mongodb-enterprise-mongos=4.0.8 mongodb-enterprise-tools=4.0.8
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libcurl3 (>= 7.16.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.