mongod.service Failed with result core-dump

Hi Mongodb OPS and Sysad,

I’m new to mongodb and currently working on a virtual machine installed with redhat. it happens that we tried to change the permission of the following while adding the keyfile on the security option under /etc/mongod.conf

image

then we restart the mongodb using the command systemctl restart mongod

here’s the error:

● mongod.service - MongoDB Database Server
Loaded: loaded (/usr/lib/systemd/system/mongod.service; enabled; vendor pres>
Active: failed (Result: core-dump) since Wed 2021-02-24 13:41:34 PST; 1 day >
Docs: https://docs.mongodb.org/manual
Process: 1279 ExecStart=/usr/bin/mongod $OPTIONS (code=dumped, signal=ABRT)
Process: 1277 ExecStartPre=/usr/bin/chmod 0755 /var/run/mongodb (code=exited,>
Process: 1274 ExecStartPre=/usr/bin/chown mongod:mongod /var/run/mongodb (cod>
Process: 1271 ExecStartPre=/usr/bin/mkdir -p /var/run/mongodb (code=exited, s>

mongod[1279]: mongod(_ZN5mongo11Initial>
mongod[1279]: mongod(_ZN5mongo21runGlob>
mongod[1279]: mongod(+0xD9DF2A) [0x560b>
mongod[1279]: mongod(+0xD1F719) [0x560b>
mongod[1279]: libc.so.6(__libc_start_ma>
mongod[1279]: mongod(_start+0x2E) [0x56>
mongod[1279]: ----- END BACKTRACE -----
systemd[1]: mongod.service: Control proc>
systemd[1]: mongod.service: Failed with >
systemd[1]: Failed to start MongoDB Data>

I tried to uninstall using this command below:

sudo service mongod stop
sudo apt-get purge mongodb-org*

Remove Data Directories.
Remove MongoDB databases and log files.

sudo rm -r /var/log/mongodb
sudo rm -r /var/lib/mongodb

And fresh install mongodb to another version same thing happened error message didn’t disappeared and mongodb service failed to start.

Mongodb Current Version: MongoDB shell version v4.2.8
OS: Red Hat Enterprise Linux release 8.2 (Ootpa)

Hoping from this forum someone can help me on this issue and able to share some ideas to fix it. Thank you in advance.