Mongod looking for /data/db

Hi,

For database host, does anyone having this issue like me? mongod is looking for /data/db when starting up. However, the mongod.conf is with default location of /var/lib/mongod for dbPath and mongod should take default option.

Thanks,
Silaphet

Had the same issue, run a ‘sudo mkdir /data/db’ , ‘sudo mkdir /data/log’ it went away, hope it helps.

Hi,
What did not have problem getting the mongod up running. What I really don’t understand why mongod does not use default location from the /etc/mongod.conf? It seems mongod does not read this conf file then.

having the same problem
in mongo.conf dbPath: /var/lib/mongodb

tried to run mongod with the following command:
mongod --dbpath /var/lib/mongodb --auth
but it stuck in
I NETWORK [HostnameCanonicalizationWorker] Starting hostname canonicalization

should I remove the machines and vagrant and install them again.
I’m using windows 10.

Hi Shamsan_93091,

I suggest using the --fork option. And recommend checking out the following discussions.

Hope that helps,

David

data/db

hostnamecanonicalizationworker