Mongod logs not showing a new connection after mongo client is lauched

I’m using a Windows machine for this, and running the commands on command prompt.
After running the mongod command at first, the following is the console output:

C:\WINDOWS\system32>mongod
{“t”:{"$date":“2020-12-27T13:36:55.242+05:30”},“s”:“I”, “c”:“CONTROL”, “id”:23285, “ctx”:“main”,“msg”:“Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols ‘none’”}
{“t”:{"$date":“2020-12-27T13:36:55.638+05:30”},“s”:“W”, “c”:“ASIO”, “id”:22601, “ctx”:“main”,“msg”:“No TransportLayer configured during NetworkInterface startup”}
{“t”:{"$date":“2020-12-27T13:36:55.638+05:30”},“s”:“I”, “c”:“NETWORK”, “id”:4648602, “ctx”:“main”,“msg”:“Implicit TCP FastOpen in use.”}
{“t”:{"$date":“2020-12-27T13:36:55.647+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:4615611, “ctx”:“initandlisten”,“msg”:“MongoDB starting”,“attr”:{“pid”:17120,“port”:27017,“dbPath”:“C:/data/db/”,“architecture”:“64-bit”,“host”:“W1851604”}}
{“t”:{"$date":“2020-12-27T13:36:55.648+05:30”},“s”:“I”, “c”:“CONTROL”, “id”:23398, “ctx”:“initandlisten”,“msg”:“Target operating system minimum version”,“attr”:{“targetMinOS”:“Windows 7/Windows Server 2008 R2”}}
{“t”:{"$date":“2020-12-27T13:36:55.649+05:30”},“s”:“I”, “c”:“CONTROL”, “id”:23403, “ctx”:“initandlisten”,“msg”:“Build Info”,“attr”:{“buildInfo”:{“version”:“4.4.2”,“gitVersion”:“15e73dc5738d2278b688f8929aee605fe4279b0e”,“modules”:,“allocator”:“tcmalloc”,“environment”:{“distmod”:“windows”,“distarch”:“x86_64”,“target_arch”:“x86_64”}}}}
{“t”:{"$date":“2020-12-27T13:36:55.656+05:30”},“s”:“I”, “c”:“CONTROL”, “id”:51765, “ctx”:“initandlisten”,“msg”:“Operating System”,“attr”:{“os”:{“name”:“Microsoft Windows 10”,“version”:“10.0 (build 18363)”}}}
{“t”:{"$date":“2020-12-27T13:36:55.656+05:30”},“s”:“I”, “c”:“CONTROL”, “id”:21951, “ctx”:“initandlisten”,“msg”:“Options set by command line”,“attr”:{“options”:{}}}
{“t”:{"$date":“2020-12-27T13:36:55.666+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22270, “ctx”:“initandlisten”,“msg”:“Storage engine to use detected by data files”,“attr”:{“dbpath”:“C:/data/db/”,“storageEngine”:“wiredTiger”}}
{“t”:{"$date":“2020-12-27T13:36:55.666+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22315, “ctx”:“initandlisten”,“msg”:“Opening WiredTiger”,“attr”:{“config”:“create,cache_size=15747M,session_max=33000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000,close_scan_interval=10,close_handle_minimum=250),statistics_log=(wait=0),verbose=[recovery_progress,checkpoint_progress,compact_progress],”}}
{“t”:{"$date":“2020-12-27T13:36:55.690+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:689724][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY_PROGRESS] Recovering log 6 through 7"}}
{“t”:{"$date":“2020-12-27T13:36:55.732+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:731775][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY_PROGRESS] Recovering log 7 through 7"}}
{“t”:{"$date":“2020-12-27T13:36:55.775+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:775760][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY | WT_VERB_RECOVERY_PROGRESS] Main recovery loop: starting at 6/5632 to 7/256"}}
{“t”:{"$date":“2020-12-27T13:36:55.857+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:856776][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY_PROGRESS] Recovering log 6 through 7"}}
{“t”:{"$date":“2020-12-27T13:36:55.912+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:912766][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY_PROGRESS] Recovering log 7 through 7"}}
{“t”:{"$date":“2020-12-27T13:36:55.954+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:953775][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY | WT_VERB_RECOVERY_PROGRESS] Set global recovery timestamp: (0, 0)"}}
{“t”:{"$date":“2020-12-27T13:36:55.954+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“initandlisten”,“msg”:“WiredTiger message”,“attr”:{“message”:"[1609056415:954726][17120:140727840956064], txn-recover: [WT_VERB_RECOVERY | WT_VERB_RECOVERY_PROGRESS] Set global oldest timestamp: (0, 0)"}}
{“t”:{"$date":“2020-12-27T13:36:55.984+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:4795906, “ctx”:“initandlisten”,“msg”:“WiredTiger opened”,“attr”:{“durationMillis”:318}}
{“t”:{"$date":“2020-12-27T13:36:55.984+05:30”},“s”:“I”, “c”:“RECOVERY”, “id”:23987, “ctx”:“initandlisten”,“msg”:“WiredTiger recoveryTimestamp”,“attr”:{“recoveryTimestamp”:{"$timestamp":{“t”:0,“i”:0}}}}
{“t”:{"$date":“2020-12-27T13:36:55.990+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:4366408, “ctx”:“initandlisten”,“msg”:“No table logging settings modifications are required for existing WiredTiger tables”,“attr”:{“loggingEnabled”:true}}
{“t”:{"$date":“2020-12-27T13:36:55.991+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:22262, “ctx”:“initandlisten”,“msg”:“Timestamp monitor starting”}
{“t”:{"$date":“2020-12-27T13:36:56.004+05:30”},“s”:“W”, “c”:“CONTROL”, “id”:22120, “ctx”:“initandlisten”,“msg”:“Access control is not enabled for the database. Read and write access to data and configuration is unrestricted”,“tags”:[“startupWarnings”]}
{“t”:{"$date":“2020-12-27T13:36:56.005+05:30”},“s”:“W”, “c”:“CONTROL”, “id”:22140, “ctx”:“initandlisten”,“msg”:“This server is bound to localhost. Remote systems will be unable to connect to this server. Start the server with --bind_ip to specify which IP addresses it should serve responses from, or with --bind_ip_all to bind to all interfaces. If this behavior is desired, start the server with --bind_ip 127.0.0.1 to disable this warning”,“tags”:[“startupWarnings”]}
{“t”:{"$date":“2020-12-27T13:36:56.010+05:30”},“s”:“I”, “c”:“STORAGE”, “id”:20536, “ctx”:“initandlisten”,“msg”:“Flow Control is enabled on this deployment”}
{“t”:{"$date":“2020-12-27T13:36:56.253+05:30”},“s”:“I”, “c”:“FTDC”, “id”:20625, “ctx”:“initandlisten”,“msg”:“Initializing full-time diagnostic data capture”,“attr”:{“dataDirectory”:“C:/data/db/diagnostic.data”}}
{“t”:{"$date":“2020-12-27T13:36:56.268+05:30”},“s”:“I”, “c”:“NETWORK”, “id”:23015, “ctx”:“listener”,“msg”:“Listening on”,“attr”:{“address”:“127.0.0.1”}}
{“t”:{"$date":“2020-12-27T13:36:56.268+05:30”},“s”:“I”, “c”:“NETWORK”, “id”:23016, “ctx”:“listener”,“msg”:“Waiting for connections”,“attr”:{“port”:27017,“ssl”:“off”}}

After running mongo in another shell, I’m not seeing a “connection accepted”, or any other similar message on the first (mongod) shell, as mentioned in the Chapter 1 lecture. I also added a collection, but again, no acknowldement of that in the mongod shell output.

There seems to be some issue with the connection. How do I identify/resolve the isse?

It should show.May be because of default mongod on port 27017
Check the mongod.log

or start another mongod on a different port and connect using mongo --port port_num

Post a screenshot of the other shell where you connected with the mongo command.

@Ramachandra_37567 using the --port option with the mongo command command worked. The connection is reflecting in the mongod shell. Thanks!