Mongod is not installed

After downloading the course material and vagrant installation, I run these commands without any error:
cd m310-vagrant-env vagrant plugin install vagrant-vbguest
$ vagrant up
Then I connect to the database using: vagrant up and vagrant ssh database, but while I want to run mongod, I face with this message: “The program ‘mongod’ is currently not installed. To run ‘mongod’ please ask your administrator to install the package ‘mongodb-server’”
I retried the following commands:
vagrant reload database
vagrant provision database
but the problem exists and during logs, I could find this:
GPG error: http://repo.mongodb.com trusty/mongodb-enterprise/3.2 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY D68FA50FEA312927

I am experiencing this same issue. Any ideas? Thanks.

Please check this link

Database Machine

1 Like

I have tried the steps from (Database Machine) and it seemed to work for the database VM, but for the infrastructure VM MongoDB is not installed. Here’s the error I receive:
[vagrant@infrastructure ~]$ mongod

-bash: mongod: command not found

[vagrant@infrastructure ~]$ apt-get install -y mongodb-enterprise --force-yes

-bash: apt-get: command not found

[vagrant@infrastructure ~]$ sudo apt-get install -y mongodb-enterprise --force-yes

sudo: apt-get: command not found

[vagrant@infrastructure ~]$

It’s not required. You’re good to carry on with the course.

2 Likes