Mongo shell - cant load loadMovieDetailsDataset.js

Hey guys, I just downloaded mongoshell from website (new version called “mongosh”, not “mongo” anymore).

I’m getting this error:

load("/loadMovieDetailsDataset.js")
ReferenceError: load is not defined

You have to use mongo, not mongosh. The mongosh is new technology and the syntax is different.

Hi @Jpehcl,

We have not tested our content on mongosh. Please follow the instructions mentioned in the course lecture for downloading and installing mongo shell on your system.

Thanks,
Shubham

Ok “legacy mongo” worked fine. Thank you.

Btw on mongodb download page, only mongosh es available to download.

As per my knowledge, traditionally mongo shell has been distributed as part of the Enterprise Server or Community Server but I will check with the relevant team.

Thanks,
Shubham

I ended up downloading mongosh by mistake.

and used

.load loadMovieDetailsDataset.js

as per the documentation Require a file and it worked.

1 Like

Hi @Anjali_Raghav,

I’m glad it worked for you. As you know it’s a new product, so new features are being continuously added to it.

~ Shubham