Mongo: /lib64/libc.so.6: version `GLIBC_2.6' not found (required by mongo)

Am getting the below error while running the mono --nodb command on RHEL 5

[mongo@rac1 ~]$ mongo --nodb
mongo: /lib64/libc.so.6: version GLIBC_2.6' not found (required by mongo) mongo: /lib64/libc.so.6: version GLIBC_2.7’ not found (required by mongo)
mongo: /lib64/libc.so.6: version GLIBC_2.8' not found (required by mongo) mongo: /lib64/libc.so.6: version GLIBC_2.9’ not found (required by mongo)
mongo: /lib64/libpthread.so.0: version GLIBC_2.12' not found (required by mongo) mongo: /lib64/libresolv.so.2: version GLIBC_2.9’ not found (required by mongo)

Below may help you