May Know if my shell is correct?

I use
C:\Windows\system32\cmd.exe
It doesn’t take the commands: mongod, mongo

Thank you for your kind services.
Paul-A. Dupuis

It’s unlikely there is an issue with your shell.
mongo needs to be installed, and on windows I believe you need to provide the full path to the executable file.

For the purpose of this course see:
https://university.mongodb.com/mercury/M103/2018_October/chapter/Chapter_0_Introduction_Setup/lesson/59f3524b573387e2caea7fbc/tab/59f35260573387e2caea7fbd

To follow up with Ben: what you’re looking for specifically, is updating Windows’ %PATH% variable, so it include the directory with Mongo’s commands.

Hi Paulandredupuis,

Please set your environment path variable after installing MongoDB. Follow these steps:

  1. Select Start, select Control Panel. double click System, and select the Advanced tab.
  2. Click Environment Variables . …
  3. In the Edit System Variable (or New System Variable ) window , specify the value of the PATH environment variable .
  4. Click OK . Close all remaining windows by clicking OK .

Restart your Command Prompt after setting your Environment variable.

If you have done that check if it is mentioned and updated corrected. Run this command from command prompt:

C:\Users\Kanika> set

18%20PM
Screen Shot 2018-10-22 at 6.13.18 PM.png993x566 53.8 KB

Let me know!

Kanika