M320-96m7e.mongodb.net unable to ping this server

I am unable to connect to m320-96m7e.mongodb.net using compass as described in lesson. I could not ping the server. Connection details as below

M320 Atlas Cluster Connection Information

  • Hostname : m320-96m7e.mongodb.net
  • SRV Record : ON
  • Authentication : Username / Password
  • Username : m320-student
  • Password : m320-password

below is the error

MongoDB not running on the provided host and port

Outgoing port tester

This server listens on all TCP ports, allowing you to test any outbound TCP port.

You have reached this page on port 27017 .

Your network allows you to use this port. (Assuming that your network is not doing advanced traffic filtering.)

Network service: unknown
Your outgoing IP: 72.73.235.183

also C:\Users\kgadd>ping portquiz.net

Pinging portquiz.net [52.47.209.216] with 32 bytes of data:
Reply from 52.47.209.216: bytes=32 time=88ms TTL=49
Reply from 52.47.209.216: bytes=32 time=90ms TTL=49
Reply from 52.47.209.216: bytes=32 time=87ms TTL=49
Reply from 52.47.209.216: bytes=32 time=88ms TTL=49

Ping statistics for 52.47.209.216:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 87ms, Maximum = 90ms, Average = 88ms

but I can’t ping

C:\Users\kgadd>ping m320-96m7e.mongodb.net
Ping request could not find host m320-96m7e.mongodb.net. Please check the name and try again.

The connection settings you used are correct.
Would you verify that the port 27017 is not blocked by your organization by going to the following URL:

http://portquiz.net:27017

Regards,
MongoDB University.

Neither do I, to m320-96m7e.mongodb.net. Tks

Escolaris,

what is the page saying when you try to navigate to: http://portquiz.net:27017/

Regards,
MongoDB University

Outgoing port tester

This server listens on all TCP ports, allowing you to test any outbound TCP port.

You have reached this page on port 27017 .

Your network allows you to use this port. (Assuming that your network is not doing advanced traffic filtering.)

Network service: unknown
Your outgoing IP: 186.31.44.210

Escolaris,

Since your connection parameters are good and the firewall does not block this port, it should work.
Note that the firewall may be blocking this specific set of address and port, however, it is unlikely.

Here are few options you can try:

A) If you have the connection information as a “Favorite”. Go ahead and delete this favorite and enter the connection information again.

B) Exit Compass, ensure the process is not running anymore, then start Compass again.

C) Re-install Compass.

If you still have issues after doing C), would you report the version of Compass you are using?

Regards,
MongoDB University.

Hi Escolaris,

I am able to connect to it using mongo shell. But not thru compass. I have deleted favorites, other connections and made sure no other connections exist in left pane, logged out, uninstalled it, installed 1.18 64bit windows version using msi and still could not connect thru compass. but it works from mongo shell as below.

mongo “mongodb+srv://m320-96m7e.mongodb.net” --username m320-student --authenticationDatabase admin

Thanks
Karunakaran

sorry. addressed to Escolaris. I meant to address it to Daniel

I have the same problem. I could not connect through compass (with SRV Record turned on), but I could connect without problems throught the mongo shell. I could connect to compass with SRV Record turned off, using host m320-shard-00-00-96m7e.mongodb.net. and port 27017 (this data appeared in the console when connecting through the mongo shell), but I find it very strange that the host name ends in a full stop.
Is there any solution for connecting to compass using the SRV Record?

Thanks and best regards,
Bea

Hi @bszalay26,

Please try after removing the full stop character. Here is my compass connection for M320:

Kanika

Hi
I couldn’t connect through the compass (with SRV Record enabled), but I could connect without problems through the mongo shell.
Is there a solution to use the compass using the SRV register?

Your parameters look good.
I just tried with 1.19.6 on Mac, and it works well.

  1. what is the OS and version you are using?
  2. try terminating the Compass process and then connecting again

Regards,
Daniel

I am also not able to connect to m320-96m7e.mongodb.net
I have tried following

  1. Connecting through mongo but not succeeded.
  2. No reply on ping
  3. http://portquiz.net:27017/ is also not responding for me.

Please can someone help?

If you are not getting an answer from "http://portquiz.net:27017/ ", it is most likely that the port is blocked by a firewall on your machine or by the corporate firewall where you work.
If it is the former, you will need to open the port.
If it is the latter, try connecting with the machine from outside the organization if it is a laptop.

Please note, that the use of Atlas is completely optional for this course.
You can complete all exercises in the course without connecting to Atlas.

Regards,
Daniel.

1 Like

Thank you for your reply Daniel, It is latter case and using private connection dos solved the issue.

Have a nice time!!

BR
Atul