M312 Chapter 3 : Lab: Analyse Profiler Data - mlaunch

I’m running mlaunch --single , getting the following error

about to fork child process, waiting until server is ready for connections.
forked process: 13563
ERROR: child process failed, exited with error number 14

can’t start process, return code 14. tried to launch: “mongod” --dbpath “/shared/data/db” --logpath “/shared/data/mongod.log” --port 27017 --fork --wiredTigerCacheSizeGB 1

Looking at the mongod.log , here is what i see

2020-11-02T01:32:39.966+0000 I CONTROL [initandlisten] options: { net: { port: 27017 }, processManagement: { fork: true }, storage: { dbPath: “/shared/data/db”, wiredTiger: { engineConfig: { cacheSizeGB: 1.0 } } }, systemLog: { destination: “file”, path: “/shared/data/mongod.log” } }
2020-11-02T01:32:39.987+0000 I STORAGE [initandlisten] wiredtiger_open config: create,cache_size=1024M,session_max=20000,eviction=(threads_max=4),config_base=false,statistics=(fast),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),checkpoint=(wait=60,log_size=2GB),statistics_log=(wait=0),
2020-11-02T01:32:40.030+0000 E STORAGE [initandlisten] WiredTiger error (22) [1604280760:30355][13563:0x7f178bc62d00], connection: /shared/data/db/: directory-sync: fdatasync: Invalid argument
2020-11-02T01:32:40.032+0000 I - [initandlisten] Fatal Assertion 28561 at src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine.cpp 264
2020-11-02T01:32:40.032+0000 I - [initandlisten]

***aborting after fassert() failure

I tried to vagrant destroy and vagrant up . Sill get this error when starting mlaunch --single

Thankks

its working now . I was in the /shared directory .

Per the instructions , when i ran this from /home/vagrant , it started up fine .

Thanks.

Thats awesome @Dinesh_Boara! :slight_smile:

Kanika