M310 Vagrant env setup

Encountering error while vagrant is trying to download mongodb.

database: Err http://repo.mongodb.com trusty/mongodb-enterprise/3.2 InRelease
database:
database: Err http://repo.mongodb.com trusty/mongodb-enterprise/3.2 Release.gpg
database: Could not resolve ‘repo.mongodb.com

database: Reading package lists…
database: W
database: :
database: Failed to fetch http://repo.mongodb.com/apt/ubuntu/dists/trusty/mongodb-enterprise/3.2/InRelease
database: W
database: :
database: Failed to fetch http://repo.mongodb.com/apt/ubuntu/dists/trusty/mongodb-enterprise/3.2/Release.gpg Could not resolve ‘repo.mongodb.com
database: W
database: :
database: Some index files failed to download. They have been ignored, or old ones used instead.
database: + install_mongod
database: + echo ‘Install MongoDB Enterprise’
database: Install MongoDB Enterprise
database: + apt-get install -y mongodb-enterprise --force-yes
database: Reading package lists…
database: Building dependency tree…
database: Reading state information…
database: E
database: :
database: Unable to locate package mongodb-enterprise
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

svr:m310-vagrant-env tkdutta$ vagrant status
Current machine states:

database running (virtualbox)
infrastructure not created (virtualbox)

Any ideas?

Are you working on your work system? Make sure your network allows incoming connections or maybe the firewall is enabled.

Try opening http://repo.mongodb.com link from your system, if you are unable to open, you might need to ask IT team or try from different machine.

Kanika

Hi Kanika,

On the same system I was able to get m103 to work successfully.
I am able to ping http://repo.mongodb.com just fine!

Thanks
Tandav

Hi Kanika,

Maybe its a system/firewall/network issue; i will try later and revert.
Thanks for your prompt response.

Thanks
Tandav

1 Like