M310 Plugin Failed to Load

Hello,

when running vagrant up i get the following error:

C:\Education\MongoDB_University\M310_MongoDB_Security\m310-vagrant-env>vagrant plugin install vagrant-vbguest
Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
Installed the plugin ‘vagrant-vbguest (0.20.0)’!

C:\Education\MongoDB_University\M310_MongoDB_Security\m310-vagrant-env>vagrant up
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

cannot load such file – vagrant/vbguest

May be incompatible versions
Please check this link.May help

Hello,

that sugestion does not seem to be working. I’ve uninstalled everything including Vagrant, clean folders on my user account, mainly .gem and .vagrant folders, installed vagrant again and the plugin and the error is the same. It seems to be a problem with the plugin itself.

If i install the plugin vagrant-vbguest i get the same error. I cannot even get the vagrant version:


C:\Education\MongoDB_University\M310_MongoDB_Security\m310-vagrant-env>vagrant version
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

cannot load such file – vagrant/vbguest


Once i uninstall the plugin the same command gets to work:

C:\Education\MongoDB_University\M310_MongoDB_Security\m310-vagrant-env>vagrant plugin uninstall vagrant-vbguest
Uninstalling the ‘vagrant-vbguest’ plugin…
Successfully uninstalled micromachine-3.0.0
Successfully uninstalled vagrant-vbguest-0.20.0

C:\Education\MongoDB_University\M310_MongoDB_Security\m310-vagrant-env>vagrant version
Installed Version: 2.2.6
Latest Version: 2.2.6

You’re running an up-to-date version of Vagrant!

I don’t really know what to do next.

Hi @jplourenco,

After plugin uninstallation, what is the output of vagrant up ?

Kanika

Hello ,

the result:

vagrant version
Installed Version: 2.2.6
Latest Version: 2.2.6

You’re running an up-to-date version of Vagrant!

And when you do vagrant ssh?

vagrant ssh
This command requires a specific VM name to target in a multi-VM environment.

Oh! I am sorry, you need to use environment name here.

For infrastructure: vagrant ssh infrastructure

For database: vagrant ssh database

And if you are able to ssh, you are good to go for the course. :slight_smile:

Kanika