M310 installation error - vagrant up infrastructure

Hello

I have got past the error for vagrant up database. but i get the following for infrastructure, seems url for the centos version for this install has changed. Please see below:

failure: repodata/repomd.xml from C7.7.1908-base: [Errno 256] No more mirrors to try.
http://vault.centos.org/7.7.1908/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

I have been through the vagrant provision file to see if i could amend any line to use alternative url. Any help most appreciated.

kind regards

Let’s see a full screenshot (including the vagrant command).

Hello

I run ‚Äúvagrant up infrastructure‚ÄĚ in windows at cmd line. Below is the error i get.

Just tried it and was faced with the same error message as you. It was however resolved by running these:

vagrant plugin install vagrant-vbguest
vagrant up infrastructure

Hello

i removed infrastructure:
vagrant halt infrastructure
vagrant destroy infrastructure

Then i ran:
vagrant plugin install vagrant-vbguest
vagrant up infrastructure

I still get the same error… :thinking:

Here’s exactly what I just did:

  1. vagrant up infrastructure - it failed here
  2. vagrant plugin install vagrant-vbguest
  3. vagrant up infrastructure

Did the plugin install without errors?

Hello

Below is what was run for the plugins + output.

vagrant plugin install vagrant-vbguest
Installing the ‚Äėvagrant-vbguest‚Äô plugin. This can take a few minutes‚Ķ
Installed the plugin ‚Äėvagrant-vbguest (0.23.0)‚Äô!

I hit the same issue. looks like this path is invalid as I tried to navigate thru the same path and found the following error shown on the page.

The install instruction needs to include some other mirror image to ensure it goes thru fine.

1 Like

This issue is stopping me from proceeding.

Hello,
I get exactly the same error. Please, can you resolve as soon as possible?
Thanks

Hello

I managed to hack around the issue.
After running ‚Äúvagrant up infrastructure‚ÄĚ a second time i had a vm that was up and running, but no shared folder.

once infrastructure was up but no shared folder, i ssh to infrastructure and ran as below:

sudo yum update -y

Then once that completed I disconnected from ssh and re-ran
vagrant plugin install vagrant-vbguest
‚Äúvagrant reload infrastructure‚ÄĚ
‚Äúvagrant up infrastructure --provision‚ÄĚ

I now have a vm with shared folder.

4 Likes

Hi,
it worked for me too. I also had to run the following command:

‚Äúvagrant reload infrastructure‚ÄĚ

because ‚Äúvagrant reload --provision‚ÄĚ has errors

Thanks

1 Like

I believe the broken link or the defunct mirror was removed.

Here is what I did to mitigate the issue

From your local host:

vagrant up database (this doesnt go thru fully as the install steps were failing)

Then logged into the vm and did the following:

echo ‚Äúdeb [ arch=amd64 ] https://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.6 multiverse‚ÄĚ | sudo tee /etc/apt/sources.list.d/mongodb-org-3.6.list

sudo rm /etc/apt/sources.list.d/mongodb-org-4.2.list

ls -altr /etc/apt/sources.list.d/mongodb-org*. (made sure only 3.6 list is in place)

sudo apt-get update

sudo apt-get install mongodb-org

The x86_64 sub-folder now exists in the Vault repo, however, it currently has no content. Pretty sure it’ll be updated soon. Secondly, your yum’s fastest mirror (based on geo location) doesn’t yet have the content.

Good workaround from @mandeep_60793. Other workarounds are:

  1. VPN to another country (Denmark, Singapore, UK) so that it uses a different fast mirror
    > Destroy (vagrant destroy -f infrastructure)
    > Bring it up (vagrant up infrastructure)

Or

  1. Update the baseurl of /etc/yum.repos.d/CentOS-Vault.repo for C7.7.1908:

Or

  1. Turn off yum’s fastestmirror and it might pick one that has the recent content (even if it’s slower):
    • Destroy > Bring it up > SSH
    •  a) sudo vi /etc/yum/pluginconf.d/fastestmirror.conf
       b) Change enabled=1 to enabled=0
       c) sudo yum clean all
      
    • Reload

PS: MongoDB is not required in this infrastructure machine.

FYI

The Vault repo has now been fixed (i.e. x86_64/ sub-folder has been created) so vagrant up should work without any additional steps:

Hi All,

Thank you all for reporting this issue and finding the workarounds regarding the same.

I will definitely take a look here and see what quick fixes we can provide to the users.

Please feel free to reach out if you have any questions or thoughts around this.

Thanks,
Sonali

provision-database and provision-infrastructure files seems wrong because I cannot complete this step since last one week. I have tried with all versions of vagrant and virtual box for windows 10 but doesn’t work at all. Even I have enabled Virtual Machine setting from BIOS but no hope. Can anyone please quickly provide solution as the lab due date is coming closed ? command is also stucked after database: SSH auth method: private key.

@yatinpatel13983, please create a new thread with your query and someone will assist. Remember to include full details of the error message and the command you ran.

Hi!

This probably seems a long time ago for you, but I am facing a similar issue just now.
I have tried to follow what you do and still have no shared directory on the VM.

I have one question, when you first run ‚Äúvagrant up infrastructure‚ÄĚ, inside your Vagrantfile, do you have this line?

infrastructure.vm.box = "centos/7"

Or do you have something else instead of ‚Äúcentos/7‚ÄĚ ?