M103 - not able to connect mongod

I am getting this error " The program ‘mongod’ is currently not installed."
Not sure what went wrong. I have completed lab till creating ‘m103-admin’ and was in process of creating config file.

I am getting below error:
vagrant@m103:~$ mongod
The program ‘mongod’ is currently not installed. To run ‘mongod’ please ask your
administrator to install the package ‘mongodb-server’

Can someone responsd please???

Hi @S_H_24546,

Please share the screenshot of the config file, the command you used to launch mongod and the error that you are getting.
Also, check the mongo version using the following command:

mongo --version

Thanks,
Sonali

I am able to connect Mongod/mongo outside vagrant but getting above error when via vagrant.

MongoDB shell version v4.
git version: 3739429dd92b
allocator: tcmalloc
modules: enterprise
build environment:
distmod: windows-64
distarch: x86_64
target_arch: x86_64


Here is the screenshot:

Further update, using vagrant session reinstalled packages.( using link: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/)

Now the mongod session gets closed itself. Here is the screenshot:error2

Hi @S_H_24546,

Can you please try launching mongod with basic configurations?

You can use the following commands:

mkdir first_mongod
mongod --port 30000 --dbpath first_mongod --logpath first_mongod/mongod.log --fork

Please share the screenshot of the output you get after this command.

Thanks,
Sonali

error3

Can someone help please? ‘mongod’ just doesn’t connect via vagrant. It connects perfectly outside vagrant.

From your last screen dump mongod started successfully.

You should try to connect with ‘mongo --port 30000’.

Thankyou Steeve …I missed lab session of Chap 1 due to time constraint.