Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

M103-Lab - Launching Mongod

I’m running through the m103 lab and unable to launch mongod using the following command line:

mongod --port 27000 --bind_ip “localhost, 192.168.103.100” --dbpath “\data\db” --auth

Output:

mongod --port 27000 --bind_ip "localhost, 192.168.103.100" --dbpath "\data\db\" --auth
2020-03-27T09:26:35.171+1100 I  CONTROL  [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'
2020-03-27T09:26:35.604+1100 W  ASIO     [main] No TransportLayer configured during NetworkInterface startup
2020-03-27T09:26:35.606+1100 I  CONTROL  [initandlisten] MongoDB starting : pid=20124 port=27000 dbpath=\data\db" --auth 64-bit host=MatinauSurface
2020-03-27T09:26:35.606+1100 I  CONTROL  [initandlisten] targetMinOS: Windows 7/Windows Server 2008 R2
2020-03-27T09:26:35.606+1100 I  CONTROL  [initandlisten] db version v4.2.5
2020-03-27T09:26:35.606+1100 I  CONTROL  [initandlisten] git version: 2261279b51ea13df08ae708ff278f0679c59dc32
2020-03-27T09:26:35.607+1100 I  CONTROL  [initandlisten] allocator: tcmalloc
2020-03-27T09:26:35.607+1100 I  CONTROL  [initandlisten] modules: none
2020-03-27T09:26:35.607+1100 I  CONTROL  [initandlisten] build environment:
2020-03-27T09:26:35.607+1100 I  CONTROL  [initandlisten]     distmod: 2012plus
2020-03-27T09:26:35.607+1100 I  CONTROL  [initandlisten]     distarch: x86_64
2020-03-27T09:26:35.608+1100 I  CONTROL  [initandlisten]     target_arch: x86_64
2020-03-27T09:26:35.608+1100 I  CONTROL  [initandlisten] options: { net: { bindIp: "localhost, 192.168.103.100", port: 27000 }, storage: { dbPath: "\data\db" --auth" } }
2020-03-27T09:26:35.611+1100 E  STORAGE  [initandlisten] Failed to set up listener: SocketException: The requested address is not valid in its context.
2020-03-27T09:26:35.612+1100 I  CONTROL  [initandlisten] now exiting
2020-03-27T09:26:35.612+1100 I  CONTROL  [initandlisten] shutting down with code:48

Vagrant is running as instructed “mongod-m103” which is displayed in the VirtualBox Manager.

Any ideas what I’m doing wrong? If I remove “192.168.103.100” from the bind_ip argument the mongod instance is created successfully but then I cannot validate from vagrant.

MongoDB university has its own forum to discuss issues with the course labs. For m103, it is https://discourse.university.mongodb.com/c/M103/9

For this particular lab there is an issue with the validation script that makes the validation fails because of the extra space you have between local and 192.168.103.100.

1 Like

Thanks Steeve and apologizes for posting here. I’ll visit the link, unfortunately removing the space didn’t help.

I have just notice something else. The lab asks for data path to be /data/db and you specified \data\db.