M103 : Integrated IDE Error

Hi Team,
I am getting this error, even though I closed all browsers, cleared cache and stopped mongodb on my machine, even restarted the machine.
“You may be signed into another exercise in a different tab or window. Please close any additional open exercises and refresh this one.”

Can you help me resolve this issue.
Cannot load the integrated IDE in M103: Basic Cluster Administration Chapter 1: The Mongod

1 Like

Hi @Sunil_Ghanta,

As I can see, the In-browser IDE is loading fine for you. Can you please check ? Let me know if you are still facing any issue.

~ Shubham

Hi Shubham_Ranjan,
I am still seeing the same issue. Can you check.
What was the issue ?

Hi @Sunil_Ghanta,

Can you please share a screenshot of what you see on the screen ?

In the meantime, I’m reaching out to the platform team for the resolution of the issue.

Thanks,
Shubham

Hi @Sunil_Ghanta,

I’ve shared it with the platform team and they are looking into it. Hopefully, this issue will be resolved soon.

Thanks,
Shubham

Hi @Sunil_Ghanta,

It would be great if you can share the following information :

  1. Operating System
  2. Web browser including point version
  3. Any special browser settings (anything changed beyond default)
  4. Has the IDE ever worked for you ?
  5. Output from the developer console of your browser while you are accessing the IDE. It would be great if you can share a screenshot of it.

Here is how you can open the developer console.

Click on the vertical ellipsis sign in the top right corner of your browser and then select More Tools > Developer Tools .

Thanks,
Shubham

  1. Operating System - Windows 10
  2. Web browser including point version - Chrome V84.0.4147.135
  3. Any special browser settings (anything changed beyond default) - No
  4. Has the IDE ever worked for you ? No
  5. Output from the developer console of your browser while you are accessing the IDE. It would be great if you can share a screenshot of it.
    Attached the screenshot

Hi @Sunil_Ghanta,

Thanks for sharing the information. I’ve shared it with the team and they are looking into it.

Can you please try to use any other web browser and see if it resolves the issue so that we can rule out any issues on the client side?

Also, we are interested in the Console output.

Can you please resize this window and show all the error messages in the console ?

Thanks,
Shubham

I am getting the same error in Firefox as well.

Hi @Sunil_Ghanta,

Thanks for confirming. We are looking into it.

~ Shubham

Hi @Sunil_Ghanta,

I’ve read that you’ve already restarted and cleared browser cache.
When I had the same problem, I’ve deleted all files of the browser (Cookies and so on, not only the cache), and shut down the OS (restart seemed to keep some information). After that, I could connect again.

Thanks Daniel for your response. I’ve tried but no luck.
Shubham/MongoDB Team, did you find any solution to this.

Hi @Sunil_Ghanta,

We have enabled some additional logging in the tool so that we can see in the logs the reason the connection is being rejected.

Can you please do the following :

  • Open any IDE lab in M103
  • Share a screenshot of the error messages that you see in the Developer console.

Also, as I have mentioned earlier, please resize the window and share all the error messages that you see in the console.

~ Shubham

Hello to everyone. I’m trying to run the command: mongod --port 27000, but as you may see in the picture, I’m having an error.

Also, in the console I’m having the following output. I’m not really sure what should I do. I’m working on windows 10 and my browser is firefox. I have already clean cache and cookies but is still not working. I would really appreciate if someone can help me to solve this. Thanks in advance

Hello, you should put your command in the terminal and then execute this commands

After this push “Run Test” button

I hope this will help you

2 Likes

Hi @brenda_sofia,

This :point_down:t2:

You can also check the currently running mongod instances by running the following command in a new terminal :

ps -ef | grep mongod

~ Shubham

1 Like

It worked. Thank you!