M103: chapter1: Lab1

I am getting this message

vagrant@m103:~$ validate_lab_launch_mongod
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.

I have executed the Mongod process as

vagrant@m103:~$ mongod --port 27000 --bind_ip 192.168.103.100 --dbpath /data/db

##########################################################

2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] MongoDB starting : pid=7707 port=27000 dbpath=/data/db 64-bit host=m103
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] db version v3.6.12
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] git version: c2b9acad0248ca06b14ef1640734b5d0595b55f1
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1f 6 Jan 2014
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] allocator: tcmalloc
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] modules: enterprise
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] build environment:
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] distmod: ubuntu1404
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] distarch: x86_64
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] target_arch: x86_64
2019-05-15T10:22:00.325+0000 I CONTROL [initandlisten] options: { net: { bindIp: “192.168.103.100”, port: 27000 }, storage: { dbPath: “/data/db” } }
2019-05-15T10:22:00.326+0000 I - [initandlisten] Detected data files in /data/db created by the ‘wiredTiger’ storage engine, so setting the active storage engine to ‘wiredTiger’.
2019-05-15T10:22:00.326+0000 I STORAGE [initandlisten]
2019-05-15T10:22:00.327+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-05-15T10:22:00.327+0000 I STORAGE [initandlisten] ** See http://dochub.mongodb.org/core/prodnotes-filesystem
2019-05-15T10:22:00.327+0000 I STORAGE [initandlisten] wiredtiger_open config: create,cache_size=488M,session_max=20000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),compatibility=(release=“3.0”,require_max=“3.0”),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),statistics_log=(wait=0),verbose=(recovery_progress),
2019-05-15T10:22:01.651+0000 I STORAGE [initandlisten] WiredTiger message [1557915721:651393][7707:0x7fb0ea130a80], txn-recover: Main recovery loop: starting at 11/9856
2019-05-15T10:22:02.124+0000 I STORAGE [initandlisten] WiredTiger message [1557915722:124968][7707:0x7fb0ea130a80], txn-recover: Recovering log 11 through 12
2019-05-15T10:22:02.383+0000 I STORAGE [initandlisten] WiredTiger message [1557915722:383281][7707:0x7fb0ea130a80], txn-recover: Recovering log 12 through 12
2019-05-15T10:22:02.597+0000 I STORAGE [initandlisten] WiredTiger message [1557915722:597948][7707:0x7fb0ea130a80], txn-recover: Set global recovery timestamp: 0
2019-05-15T10:22:02.642+0000 I CONTROL [initandlisten]
2019-05-15T10:22:02.642+0000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled for the database.
2019-05-15T10:22:02.642+0000 I CONTROL [initandlisten] ** Read and write access to data and configuration is unrestricted.
2019-05-15T10:22:02.642+0000 I CONTROL [initandlisten]
2019-05-15T10:22:02.653+0000 I FTDC [initandlisten] Initializing full-time diagnostic data capture with directory ‘/data/db/diagnostic.data’
2019-05-15T10:22:02.656+0000 I NETWORK [initandlisten] waiting for connections on port 27000

Please Advise.

User is already created ( although the Lab suggested for “localhost” - I have replaced with the IP provided in the LAB question )

++++++++++++++++++++++++

mongo admin --host 192.168.103.100:27000 --eval ’
db.createUser({
user: “m103-admin”,
pwd: “m103-pass”,
roles: [
{role: “root”, db: “admin”}
]
})

Can you run db.getUsers ()