M001- Chapter 1- Not able to connect to in-browser IDE

Not able to connect to in-browser IDE. It shows error saying “You may be signed into another exercise in a different tab or window. Please close any additional open exercises and refresh this one.” I have closed all the tabs and using a single tab currently and even refreshed the tab but still showing the same error.

Hi,

Which browser and version are you using? (example: in Firefox go to hamburguer menu→help→about firefox for the version; similar for Chrome).

In any case you can try history → clear cache and sessions, but after a day these should be expired and you’ll be able to connect. Just for the next time.

Hi Apurv,

thought about your problem for a while. What you see, is the result of a mismatch between the state of your M001 Course - as it is stored inside Mongo University - on one hand, and the state of the “real world” - your browser, cookie and network state on the other hand.

Can you manufacture the following state of your operation system and your browser, please:

Part A – The Clean-Up:

  1. Close your browser.
  2. Delete your browser cache manually at file system level.
  3. Restart your browser again, however, just to delete all (or, at least relevant) cookies.
  4. Close your browser.
  5. Delete your browser cache, like before.

Part B – Restart M001 Course

  1. Restart your browser (after the clean-up).
  2. Log in your University account.
  3. Let the university do the “resume course” (you just press the button).
  4. Examine the situation you are thrown in (where are you, does it make sense)
  5. Try to move forward from that point on.

Hope you’ll soon find a way to move forward, Regards, M.

I am also having an issue getting the IDE to accept my connection link/URL.
I am using the following:
mongo “mongodb+srv://sandbox.rwtue.mongodb.net/sample_airbnb” --username m001-student
password: m001-mongodb-basics

However, I am still receiving no fails.




Please help. Please review & assist in where I am going wrong,
Thanks,
Angie Rollins

Hi @AngieRollinsMBA,

I’d first try replacing your current IP by 0.0.0.0/0

That helped! Thank you sooo much!!!
Angela

I have to buy you lunch!

1 Like