MongoDB.live, free & fully virtual. June 9th - 10th. Register Now

Localhost:27017 Service keeps stopping; service wont start

** UPDATED 2-23-20

Operating System: Windows 10
Install: Runs on localhost, data and log on a secure network virtual server due to PHI

v. 4.0.16 - Original Install
v. 4.2.3 - Updated to version

Has been an issue for both versions.

The Operation Could Not Be Completed

Error: 1053:
The service did not respond to the start or control request in a timely fashion.

Log:
2020-02-23T08:46:44.182-0500 I CONTROL [main] ***** SERVER RESTARTED *****
2020-02-23T08:46:44.502-0500 I CONTROL [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols ‘none’

Welcome to the forum. What version of MongoDB are you running? What OS? Is this on a physical machine or virtual?

That looks like a Windows Service error message.

What does the MongoDB logs show?

1 Like

I’ve updated the original post, it unfortunately was submitted prior to completion. It should now contain sufficient information to kick off the conversation. Thanks.

It would be helpful if we new what was before this section of the log. There should hopefully be more information in the log which could point to what’s going on.

You could also try starting the mongod.exe process manually to see if you get any other errors. Note, if the service is calling any configuration file or passing command line options, you would want to do that as well.

I haven’t had this issue recently. I’m keeping an eye on it.