Lab: Installing Vagrant

Hi,

I’m using a laptop installed with Windows 7 Home Premium 64-bit OS. I didn’t encounter any issue until I run vagrant up (please see the results below). Can I still proceed with the rest of the course for general knowledge if I can’t get vagrant running?

Thank you.


PS C:\temp\m312-vagrant-env> vagrant up
Vagrant failed to initialize at a very early stage:

The version of powershell currently installed on this host is less than
the required minimum version. Please upgrade the installed version of
powershell to the minimum required version and run the command again.

Installed version: 2

Minimum required version: 3
PS C:\temp\m312-vagrant-env>

Hi @Keng_Oon_Tan

Unfortunately, you must be able to install Vagrant as there are a number of hands-on exercises which are done using the Vagrant box for M312.

Reading the error message, it should like if you can upgrade your Powershell version from 2 to 3 that you should be able to continue and use Vagrant on your machine.

Kindest regards
Eoin