Lab Configuration file

Hy I’m trying to add the follwoing content as config file in a .yaml file :

storage:
dbPath: “/data/db/”
journal:
enabled: true
systemLog:
destination: file
path: “/var/log/mongodb/mongo.log”
logAppend: true
security:
authorization : enabled
processManagement:
fork: false
net:
bindIp: 127.0.0.1, 192.168.103.100
port: 27000
wireObjectCheck : false
unixDomainSocket:
enabled : true

The result is:
ERROR: child process failed, exited with error number 51
To see additional information in this output, start without the “–fork” option.
vagrant@m103:~ mongod --config /shared/ll.yaml vagrant@m103:~ mongod --config /shared/ll.yaml
about to fork child process, waiting until server is ready for connections.
forked process: 2398
ERROR: child process failed, exited with error number 51
To see additional information in this output, start without the “–fork” option.

If I run it without the --fork option:
vagrant@m103:~ mongod --config /shared/ll.yaml Aborted (core dumped) vagrant@m103:~

Which may be the problem?

Have you tried to run without fork option as indicated in your error message above?
Please try and see.You will get additional details on why it is failing
Most likely missing dir or wrong path or permissions issue

Yes, sorry I didn’t say it but the second part of the terminal output is the .yaml file without the “–fork” option. Wich could be the problem?

Hi @Radu_86288,

There are couple of things that I would like to mention here :

  1. Please read the instructions mentioned in the lab on Configuration files and make sure that you are specifying only those parameters in your configuration file.

  1. Make sure that the directories exist and vagrant is the owner.

  2. Get rid of all the quotes that you have used in your configuration file to avoid any error.

  3. Get rid of the space after the comma in the bindIp value.

Thanks,
Shubham Ranjan
Curriculum Services Engineer