Lab Configuration File

Hi. I am really stuck on opening Mongod using conf file. Please help. Ill try and give as much information as possible. See two messages i get below
vagrant@m103:/etc$ mongod --config mongod.conf
about to fork child process, waiting until server is ready for connections.
forked process: 1979
ERROR: child process failed, exited with error number 1
To see additional information in this output, start without the “–fork” option.
vagrant@m103:/etc$ mongod --config mongod.conf --fork
about to fork child process, waiting until server is ready for connections.
forked process: 1982
ERROR: child process failed, exited with error number 1
To see additional information in this output, start without the “–fork” option.

My config file is below

mmapv1:

wiredTiger:

where to write logging data.

systemLog:
destination: file
logAppend: true
path: /var/mongodb/db/mongod.log

network interfaces

net:
port: 27000
bindIp: “127.0.0.1,192.168.103.100”

how the process runs

processManagement:
timeZoneInfo: /usr/share/zoneinfo
fork: true

security:
authorization: enabled

operationProfiling:
mode: slowOp
slowOpThresholdMs: 50

#replication:

#sharding:

Enterprise-Only Options:

#auditLog:

#snmp

Please check mongod.log.It will give more details

or run mongod without fork option(comment this in config file or remove it)
It will show error on your terminal why it is failing

This is the message once i disable fork
2019-04-15T18:05:23.508+0000 F CONTROL [main] Failed global initialization: FileNotOpen: Failed to open “/var/mongodb/db/mongod.log”

Make the directory /var/mongodb/db/ exists.

Yep. That exists, thanks. Now i am getting below error, Any ideas please
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.

Please check our forums
Many threads on connection timeout

You have to check how mongod was started and have you created the user(m103-admin)

It will help if you post what command you run to get that error

Apologies. The command to get that error is
validate_lab_configuration_file

Hi Avinash_Jobanputra_42542

Please follow exact lab instructions
If you don’t follow dir/log paths,ports you will get validation errors
For this particular lab what is your logpath and dbpath?
Please go thru steps again and you have to create a user also

im getting this error
about to fork child process, waiting until server is ready for connections.
forked process: 3290
ERROR: child process failed, exited with error number 1
To see additional information in this output, start without the “–fork” option.

and without the fork option mongod is not running at all neither shows any error
please help

I would be very surprised by

Can you share a screen shot?

sure steve i have all the three config files as per lab .

alos if you want here is a screenshot of my config files

please help @Steve_17795
still a lots of lab remaining

Something does not add up in your screen shots.

You enter the same mongod command 5 times in row an nothing happen. In a previous message you write that it fails with “… error number 1”.

Anyway, your config file specify a log file. That’s the first place you have to look for errors.

i have fixed the issue @steevej-1495 thanks for addressing me