Lab - Change the Default DB Path - Doesn't start

First, I check all the running instances:
1

To finish it, I just do it with the following command:
sudo mongod --dbpath /data/db --shutdown

Before I created the dir with
sudo mkdir /var/mongodb/db/
2
And then i just try to run the mongod:
sudo mongod --config /shared/ll.yaml
Which content is:
storage:
dbPath: “/var/mongodb/db/”
systemLog:
destination: file
path: “/var/log/mongodb/mongo.log”
logAppend: true
security:
authorization : enabled
processManagement:
fork: false
net:
bindIp: 127.0.0.1,192.168.103.100
port: 27000

Only one line has been changed from the previous lab, the dbPath, in the previous one it worked correctly but now when i run again the mongod with the config file option it stays here and doesn’t show anything:
3

Any idea?

Thanks.

Does this exist?

Also, don’t run mongod with sudo.

Hi @Radu_86288,

In addition to @007_jb,

Did you change the ownership of the directory to Vagrant ?

Thanks,
Shubham Ranjan
Curriculum Services Engineer

4 posts were split to a new topic: Validation Script says you need to specify the dbpath as /data/db