Lab 2.0: Create an Atlas Sandbox Cluster (Ungraded)

While completing Lab 2.0: Create an Atlas Sandbox Cluster (Ungraded) as per instruction listed I was unable to see option Select Cluster Tier M0: which was listed in lab.

Does anyone faced this issue

Hi Nilesh_Hulyal_03383,

You must have already a free tier cluster. You need to create a new Project and then create a Free Tier Cluster.

If you are still running into the issue, please share the screenshot so that I can help better.

Kanika

Hi Kanikasingla,

Yes it is free tier cluster, I checked it.
I also had a query regarding
Chapter 2: The MongoDB Query Language + Atlas

Connecting to Your Sandbox Cluster from the mongo Shel

In this chapter it is advice to use 2nd option and not to us URI option.
Please refer to “Course-ConnectingtoSandboxCluster.jpg” file.

But when I logged in to MongoDB.Atlas I do not see these two option.
But web page has option as per attahced screen shot “Actual-ConnectingtoSandboxCluster.jpg”

Should I need to use option visible in "“Actual-ConnectingtoSandboxCluster.jpg” which is “Stndard connection string (shell 3.4+)”
Please advice

You need to choose option as per your Mongo version installed on your system, if you are using Mongo version >= 3.6 (Recommended), please choose first option “Short SRV connection string”.

But if you are using Mongo version 3.4, please choose “Standard connection string”.

You can check version of Mongo by:

      $ mongo --version

Kanika

Thanks Kanika for your help. Mongo version I am using is 4.0.6, so as suggested I used option “ Short SRV connection string ”, it is connecting to atlas cluster, but getting below message before connection

Error while trying to show server startup warnings: user is not allowed to do action [getLog] on [admin.]

Not sure what is this error related

This is not a potential error. This just means the user you are using to login is not authorized to do [getLog] on admin database. If you still want to give the user this permission, try changing the role to clusterMonitor: https://docs.mongodb.com/manual/reference/built-in-roles/#clusterMonitor

Also, this link describes most of the common issues: All new users, please read: these are NOT blocking errors!

Kanika

1 Like

Thank you Kanikasingla. I changed MongoDB users setting under security to admin, then not getting earlier message (Error while trying to show server startup warnings: user is not allowed to do action [getLog] on [admin.]) before connection

1 Like