Lab 1.6 - 3.2.22 - ldap not available

Looks like the database vagrant instance for Lab 1.6 doesn’t have the ability to start with ldap. How do I proceed?

vagrant@database:~/cfg$ mongo --version

MongoDB shell version: 3.2.22

vagrant@database:~/cfg$ mongod -f 0.cfg

Unrecognized option: security.ldap.servers

try ‘mongod --help’ for more information

You might have overlooked it:

The LDAP server is running and configured properly and I can authenticate against the infrastructure VM. However, the database VM comes with mongoldb 3.2.22 which doesn’t support LDAP. What do I do?

vagrant@database:~/cfg$ testsaslauthd -u adam -p webscale -f /var/run/saslauthd/mux
0: OK “Success.”

It looks like during the video course the instructor is using 3.3? Not sure the best path forward here

LDAP is installed on the infrastructure machine. The security.ldap.servers option in your config file isn’t what you need. You need to work out a way of making a connection between the two machines.

The Enabling LDAP lecture mentions a few tips.

Another tip:
saslauthd_picture
Based on the image above, saslauthd acts as the broker between the LDAP Server and MongoDB. saslauthd lives within the database machine and that’s what needs to be configured… along with the right config file options.

Thanks 007_jb. I will try to be as explicit with this as I possibly can. The “slapd” service is successfully configured and running on the infrastructure VM. From my database VM I can successfully connect and authenticate against the infrastructure VM, see command below which was run from remote “database” VM:

vagrant@database:~/cfg$ testsaslauthd -u adam -p webscale -f /var/run/saslauthd/mux
0: OK “Success.”

Here is a snippet of the MongoDB config I have on the database VM.


security:
keyFile: “/home/vagrant/cfg/shared-key”
authorization: “enabled”
ldap:
servers: “infrastructure.m310.mongodb.university”

(ignore the missing yaml indention it doesn’t format properly in this editor, it is properly indented on the database server. in fact, if I provide this configuration to a 3.6 version of MongoDB it works)

When I try to start this config with MongoDB 3.2.2 with this config from the database VM. I get the following error:

vagrant@database:~/cfg$ mongod -f 0.cfg
Unrecognized option: security.ldap.servers

Furthermore, looking at the official mongo documentation for LDAP support indicates this feature wasn’t introduced until 3.4. https://docs.mongodb.com/manual/core/security-ldap-external/

There is no LDAP support in 3.2.22

Yeah, the Preformatted Text button doesn’t work very well to preserve indentation especially on Chrome, but here’s a way to actually do it:
image
It must be 3 backtick characters and your code must be between the set of backtick blocks. Separate lines.

Understood! This config option isn’t what you need. There are two setParameter options that’ll solve the problem.

@Jacob_35779 here’s some supplementary info on this.