Kafka Connector - Minimum supported MongoDB version?

I am getting an error trying to source data from Mongo using com.mongodb.kafka.connect.MongoSourceConnector. I suspect the problem is that the Mongo I am trying to use is too old, but I cannot find a list of the supported versions in the documentation or on Github.

mongo: v3.0.12
kafka-connect-mongodb: v1.0.1

Failed to resume change stream: exception: Unrecognized pipeline stage name: ‘$changeStream’ 16436 (com.mongodb.kafka.connect.source.MongoSourceTask)

Based on the error message I’m guessing the minimum version is 3.6, but I can’t find anything about minimum supported versions in the documentation or repo.

Does anybody know where I can find the official list of supported versions? (And if not, should I open a ticket?)

:wave: Hi @Joseph_Zack and welcome to the community forums.

While I’ve not used the Kafka connecter, I can state that change streams were introduced to MongoDB in the 3.6 version, so that would be the earliest oldest version that you could potentially use. Note that MongoDB 3.6, while still supported, is quite old and once 4.4 comes out support for 3.6 will be ending soon after.

Is there a reason that you’re still using MongoDB 3.0.12? This version has been out of support for over two years now. A lot of features, security patches and performance optimizations have been made in this time.

Hi @Joseph_Zack,

The Kafka Source Connector builds on the Change Streams feature which requires a MongoDB 3.6+ replica set deployment. If you do not require failover or redundancy, you can use a single-member replica set deployment.

I could not find specific mention of supported MongoDB versions in the current Kafka Connector readme or documentation, so reported this as a documentation improvement: KAFKA-102: Document supported versions of MongoDB.

As @Doug_Duncan mentioned, the MongoDB 3.0 release series is a few years past end of life and no longer maintained or supported. I strongly recommend upgrading your deployment to a supported MongoDB server release series (currently 3.6 or newer) for continued support as well as stability and performance improvements.

Regards,
Stennie

Thank you @Stennie / @Doug_Duncan! I’m integrating with a 3rd party system so I don’t have direct control, but I will ask about upgrading. I’ll ask to upgrade to latest, so this information is very useful to help me make my case!

I am very new to Mongo, so I’m still catching up. Thank you for your help!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.