Issue related to vagrant up ubuntu/trusty could be found

Hi,I am facing one issue while executing vagrant up command.
I have checked the virtual box at the url,updated the same at the vagrant file as well as generated the new vagrant file but still ubuntu/trusty64 is not being found. Please check the screenshot and let me know what I am doing wrong…


PS C:\vms\m310-vagrant-env> vagrant plugin install vagrant-vbguest
Installing the ‘vagrant-vbguest’ plugin. This can take a few minutes…
Installed the plugin ‘vagrant-vbguest (0.22.1)’!
PS C:\vms\m310-vagrant-env> vagrant up
Bringing machine ‘database’ up with ‘hyperv’ provider…
Bringing machine ‘infrastructure’ up with ‘hyperv’ provider…
==> database: Verifying Hyper-V is enabled…
==> database: Verifying Hyper-V is accessible…
==> database: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
database: Box Provider: hyperv
database: Box Version: >= 0
==> database: Loading metadata for box ‘ubuntu/trusty64’
database: URL: https://vagrantcloud.com/ubuntu/trusty64
The box you’re attempting to add doesn’t support the provider
you requested. Please find an alternate box or use an alternate
provider. Double-check your requested provider to verify you didn’t
simply misspell it.

If you’re adding a box from HashiCorp’s Vagrant Cloud, make sure the box is
released.

Name: ubuntu/trusty64
Address: https://vagrantcloud.com/ubuntu/trusty64
Requested provider: [:hyperv]

Hi @Manish_04653,

Which version of virtualbox are you using?

You will also need to disable hyper-v in your system.
If the issue persists, try to do a fresh download and install of vagrant and then try to bring up the vagrant machine.

Please let me know, if you have any questions.

Thanks,
Sonali

Hi, Sonali,

I have already tried the same and disabled the hyper-V completely with the below command.
Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

but as default provider was set as Hyper-V for vagrant due to which this error was occurring.
It got solved, by setting virtualbox as default vagrant provider using the following command:
set VAGRANT_DEFAULT_PROVIDER=virtualbox

Also, the Virtualbox which was using was of Version 6.1.0 and current vagrant version supports till 6.0.0 only. So, I have uninstalled the virtualbox and then re-installed it with 6.0.0 version.
I am writing this so that other might get help, in case they face the same issue.

Aside: Thanks for the help.