Issue in installing compass

I have ubuntu 32 bit.But compass is available only for 64 bit.When i download and installed compass 64 bit , its not installing.Throwing wrong architecture error. Is there any other way to install and continue labs?

No i don’t think there is any other alternative
Some students attempted 32 bit with lower version of compass but that is not recommended

Thank you for your reply. So your suggestion is to change OS to 64bit, since no other way works.