InvalidSSLConfiguration

Hi,

This looks like a simple error but I am unable to connect to Mongod using the below command

mongod --dbpath /data/db --logpath /data/log/mongod.log --fork --replSet “M103” --keyFile /data/keyfile --bind_ip “127.0.0.1,192.168.0.100” --sslMode requireSSL --sslCAFile “/etc/ssl/SSLCA.pem” --sslPEMKeyFile “/etc/ssl/ssl.pem”

Error I am receiving is:
2019-07-20T15:49:56.558+0300 F CONTROL [main] Failed global initialization: InvalidSSLConfiguration: Failed to open PEM file: D:/etc/ssl/ssl.pem

I have created the folder D:/etc/ssl

Am I missing on something?

Are you using Windows or vagrant for your work?
If you are using vagrant all paths should be on unix box
Not clear with D:/etc/ssl.Some mix up between Windows and Unix dirs

Hi @Rohit_45139,

Firstly, in the labs we can omit the ssl options unless specifically mentioned in the lab.
Moreover, as mentioned by @Ramachandra_37567, the issue here is location of .pem file. You need to ensure that the ssl.pem file is in the /etc/ssl/ folder and not within the D drive.

Please let me know, if you have any questions.

Thanks,
Sonali