Installation conflicts when trying to install enterprise version of mongodb on CentOS

Hi Team,

I am trying to install the enterprise version of mongodb on linux but getting few conflicts with previous installation.

 [labhane@localhost mongodb-enterprise]$ mongo -version
MongoDB shell version: 2.6.12
[labhane@localhost mongodb-enterprise]$    

  [labhane@localhost mongodb-enterprise]$ cat /etc/os-release
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

[labhane@localhost mongodb-enterprise]$ cat /etc/yum.repos.d/mongodb-enterprise.repo
[mongodb-enterprise]
name=MongoDB Enterprise Repository
baseurl=https://repo.mongodb.com/yum/redhat/$releasever/mongodb-enterprise/4.2/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-4.2.asc
[labhane@localhost mongodb-enterprise]$ sudo yum install -y mongodb-enterprise
[sudo] password for labhane: 
Loaded plugins: fastestmirror, langpacks[labhane@localhost mongodb-enterprise]$ cat /etc/os-release
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

[labhane@localhost mongodb-enterprise]$ cat /etc/yum.repos.d/mongodb-enterprise.repo
[mongodb-enterprise]
name=MongoDB Enterprise Repository
baseurl=https://repo.mongodb.com/yum/redhat/$releasever/mongodb-enterprise/4.2/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-4.2.asc
[labhane@localhost mongodb-enterprise]$ sudo yum install -y mongodb-enterprise
[sudo] password for labhane: 
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: anorien.csc.warwick.ac.uk
 * centos-sclo-rh: mirror.sov.uk.goscomb.net
 * epel: fedora.cu.be
 * extras: mozart.ee.ic.ac.uk
 * updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package mongodb-enterprise.x86_64 0:4.2.0-1.el7 will be installed
--> Processing Dependency: mongodb-enterprise-tools = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-shell = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-server = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-mongos = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Running transaction check
---> Package mongodb-enterprise-mongos.x86_64 0:4.2.0-1.el7 will be installed
---> Package mongodb-enterprise-server.x86_64 0:4.2.0-1.el7 will be installed
--> Processing Dependency: net-snmp for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
--> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
--> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
---> Package mongodb-enterprise-shell.x86_64 0:4.2.0-1.el7 will be installed
---> Package mongodb-enterprise-tools.x86_64 0:4.2.0-1.el7 will be installed
--> Running transaction check
---> Package net-snmp.x86_64 1:5.7.2-38.el7_6.2 will be installed
---> Package net-snmp-agent-libs.x86_64 1:5.7.2-38.el7_6.2 will be installed
--> Processing Conflict: mongodb-enterprise-shell-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-server-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-tools-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-mongos-4.2.0-1.el7.x86_64 conflicts mongodb
--> Finished Dependency Resolution
Error: mongodb-enterprise-tools conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-shell conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-server conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-mongos conflicts with mongodb-2.6.12-6.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[labhane@localhost mongodb-enterprise]$ 

Loading mirror speeds from cached hostfile
 * base: anorien.csc.warwick.ac.uk
 * centos-sclo-rh: mirror.sov.uk.goscomb.net
 * epel: fedora.cu.be
 * extras: mozart.ee.ic.ac.uk
 * updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package mongodb-enterprise.x86_64 0:4.2.0-1.el7 will be installed
--> Processing Dependency: mongodb-enterprise-tools = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-shell = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-server = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Processing Dependency: mongodb-enterprise-mongos = 4.2.0 for package: mongodb-enterprise-4.2.0-1.el7.x86_64
--> Running transaction check
---> Package mongodb-enterprise-mongos.x86_64 0:4.2.0-1.el7 will be installed
---> Package mongodb-enterprise-server.x86_64 0:4.2.0-1.el7 will be installed
--> Processing Dependency: net-snmp for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
--> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
--> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: mongodb-enterprise-server-4.2.0-1.el7.x86_64
---> Package mongodb-enterprise-shell.x86_64 0:4.2.0-1.el7 will be installed
---> Package mongodb-enterprise-tools.x86_64 0:4.2.0-1.el7 will be installed
--> Running transaction check
---> Package net-snmp.x86_64 1:5.7.2-38.el7_6.2 will be installed
---> Package net-snmp-agent-libs.x86_64 1:5.7.2-38.el7_6.2 will be installed
--> Processing Conflict: mongodb-enterprise-shell-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-server-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-tools-4.2.0-1.el7.x86_64 conflicts mongodb
--> Processing Conflict: mongodb-enterprise-mongos-4.2.0-1.el7.x86_64 conflicts mongodb
--> Finished Dependency Resolution
Error: mongodb-enterprise-tools conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-shell conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-server conflicts with mongodb-2.6.12-6.el7.x86_64
Error: mongodb-enterprise-mongos conflicts with mongodb-2.6.12-6.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[labhane@localhost mongodb-enterprise]$ 

Regards,
Vaibs