Importing dataset: issues with mongorestore

Hi
I’ve just tried to import the data using mongorestore in my cmd line. as per the intructions, but get the following error:

‘mongorestore’ is not recognized as an internal or external command,
operable program or batch file.

Any help would be greatly appreciated.

Hi,
is your bin directory of MongoDB added to your PATH?

Do you have Mongodb [Shell] installed to this PC?

If yes, Do you add mongodb [shell] bin director to your environment variables?

Hi,

Yip I added the location of the mongo.exe (in the ./bin folder) to my environment variables.
In the cmd window if I type ‘mongo’ it is recognised, but mongorestore is not:
Here is the environment variable path:


And here you can see mongo runs, but mongo restore is having issues:
image

Your help would be greatly appreciated

Hi,

Ok, I suppose this is your PATH environment variable.

Have you tried using complete route to bin diecterory, i.e.: executing with complete path to mongorestore.exe

D:\python\mongodb\mongodb shell\mongodb-win32-x86_64-2008plus-ssl-4.0.4\bin\mongorestore…

Is mongorestore.exe in that windows folder?

Hmmm. I looked in the bin folder and there is no mongorestore.exe only mongo.exe. Sorry for the silly question but does it not come with the MongoDB download. Do I have to download it elsewhere and if so, where? Sorry again I am a NOOB

Hi Jacob
I had the same error, you provably downtload “mongodb-shell-win32-x86_64-2008plus-ssl-4.0.4” from Atlas --Connect with mongo shell ,

That is incomplate, you have to download it from here(like is specify in the curse):

https://www.mongodb.com/download-center/enterprise

-You have downtload it , run it and then you would have a path in your C:\ProgramFiles\MongoDB\Server\4.0\bin here have you the other executables

Thanks Enrique.
It appears as though the real issue was that if I installed it not on the C: the rest of the bin files would not install for some reason. I re-installed it on my C: and all the components seem to have been installed. A bit weird that this is a requirement, but it works.

Cheers
Jacob